lsi mega raid on primergy TX100-S3

I’ve tried to install openSuSE 12.3 on a primergy tx100 S3. Before installing I configured the lsi mega raid onboad card with the embedded software. As the openSuSE installation program reached the disk partitionning I only obtained the error -3030 and the installation was aborted.
I didn’t suspect a recognition problem of the lsi mega raid card so I’ve tried other partitionnings and other file systems. I’ve also called fujitsu support verifying that there was no harware problem on disks/card.
None of those - card is not supported !
I don’t want to do a software raid because of machine performance and because I’ve bought a server with a raid card…
Could someone tell me if there is a third party driver to install (and how) to make it operationnal ?
Or is it possible to insert a PCI-e RAID card supported by openSuSE 12.3 to do the job ?


There are known problems with RAID and 12.3 install. Looks like the best way is to install 12.2 then do an upgrade via net.

A guick look up and I can’t find a TX100-S3 card, So is this a true full RAID or a FAKE RAID card that may require drivers?

Can you boot to a LiveCD and run lspci -v? That should show you what the specific LSI card is, from which you can then determine it’s capabilities.

As for if you can obtain a PCI-e RAID card with Suse/Linux support - you bet. There are many to choose from, including from LSI and 3ware which are real RAID controller (not fakeraid). You can search their products to find one you like and which fits your budget.


I’ve dowloaded drivers from fujitsu for sles 11.3 thinking that they would install on my openSuSE 12.3 to solve this problem. But Yast detects that they are for sles 11.3 et don’t install them…

Thanks to LewsTherinTelemon
and here is the output of lspci -v
00:1f.2 RAID bus controller : Inter Corp 6 series/C200 series chipset family SATA RAID controller (rev 04)
subsystem : fujitsu Technology solutions device 11b8
Flags : bus master, 66MHz, medium devsel, latency 0, IRQ 44
I/O port at f090 [size=8]
I/O port at f080 [size=4]
I/O port at f070 [size=8]
I/O port at f060 [size=4]
I/O port at f020 [size=32]
Memory at f7f22000 (32 bit non-prefetchable) [size=2]
Capabilities : [80] MSI: enable+ Count=1/1 Maskable- 64bit-
Capabilities : [70] Powermanagment v3
Capabilities : [08] SATA HBA v1.0
Capabilities : [b0] PCI Advanced features
Kernel driver in use : ahci

Has someone an idea how to make this onboad card operationnal ?

I have the same trouble with a Fujitsu Primergy RX100 S7p. I was getting the -3030 error when I attempted installation using the network install disk, but when I use the live disk for the installation both from grub and from live boot, it freezes before even the welcome page loads (where license agreement normally is).
I have brought the machine home for the weekend to see where I can get with it, but having spent a few hours on it tonight I am no further forwards.
When I run lspci -v the result is the same as lapinux barr the memory location.

I’d be very grateful for some help with this, it is driving me round the bend.

Thanks & Best Regards