Low quality sound

my suse started working with sound automatically, however, thats a very odd type of sound that gives me impression of system speaker being used.
it is low and quailty is low as well.

in vista sound device is determined as Realtek High Definition Audio and it doesnt match anything of abbreviations yast can offer me as a sound device.

i dont yet have clear idea how to solve problems with drivers (only managed to install one for my ati - wow, now that cute chameleon looks really nice and all the vfx!) so please give me some tips which steps to make to solve this

edit: pc is toshiba satellite l300d11m

Go into yast > hardware > sound > other > volume
and ensure your volume bars are up to 70% or so (NOT 100% as that causes distortion).

Test your sound there.

Also go into your mixer (for example kmix on kde) and ensure both your Master Volume and your PCM volume are around 70 to 80% or so.

Note some media players are very sensitive to their volume control. For example if one moves the volume bar on vlc above 20% or so, one will get major distortion.

Realtek High Definition Audio is a common term, used by the producer of the audio chipset provider to Toshiba (in your case).

Thanks for tips, however, mine is set to be 68% and im comparing it to 25% in vista…

I dont really expect ‘quality’ from notebook speakers, but there is a great difference in both volume and quality.

The last one confuses me even more, i guess i’ll try to find the answer at Toshiba’s official forums…

Don’t make this more complex than it need be.

The driver that linux users typical use for sound comes with the “alsa” application. For openSUSE-11.0 it is typically version 1.0.16 of alsa. To learn more about your audio hardware and software setup, with your PC connected to the internet, copy and paste the following into a gnome-terminal or konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Thanks for tips
surprisingly i managed to set up my sound somehow, however i lost 3d support for my video :confused:
im too busy these days gonna rise the topic after awhile

Hey there, I’m new around here. I’ve used Opensuse in the past but it never could hook me up. I’m giving a try now since Opensuse 11 seems to be really good, an I could manage to configure it nicely so far, but I’m having weird problems with sound. I’ll continue this post hoping not to break any rule, just didn’t want to open a new one for the same problem.

So, I’m having pretty much the same problem. The sound I get is so choppy, often broken, and there’s almost no difference if I chage it on the speakers knob.

To give an example. I went to yast > hardware > sound > other > volume and typed 75 on the volume level number, so my sound (it was choppy already) totally disappeared.:open_mouth:
I also get bad sound quality when I play movies. For example, if I use VLC in fullscreen, the image gets sometimes kinda blocked for less than a second, then it continues. The same happens with general sound if I scroll down on firefox, for example.

I followed oldcpu instructions, so here are the results:

Alsa troubleshooting results:
tsalsa.txt - nopaste.com (beta)
rpm -qa | grep alsa**

rpm -qa | grep pulse
(nothing given here)

rpm -q libasound2

uname -a
Linux linux-7llw #1 SMP 2008-10-21 16:30:26 +0200 i686 athlon i386 GNU/Linux

cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel,snd-hda-intel

NXNs.xHzNdX5ujM2:Radeon HD 3870 Audio device

alias snd-card-0 snd-hda-intel

5Dex.g56WiP30F+E:SBx00 Azalia

alias snd-card-1 snd-hda-intel

So here’s all the info, I hope it can point to something. I also have an Ati HD3870 graphic card, wich may be the source of some trouble, since I’ve heard it’s not very well supported. Anyway, I’ve got it running with compiz effects. I don’t know if I’m using the lately released opensource driver though :\

The sort of sound behaviour you state reads to me like an interupt problem, or an interference problem with an ndiswrapper used on a wireless device. What is the output of:cat /proc/interruptsIs your sound device sharing an interrupt with many other devices?

If you boot to safe settings, and then test your sound, is it any better? Have you tried booting with an ACPI disable codes, to see if that makes a difference?

Could you provide the output of the dmesg command after a reboot? i.e., after the reboot is finished, copy and paste into a gnome-terminal or konsole: dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/athat will give you a URL. Please post that URL here

I note you have 3 sound devices:

         0 [SB             ]: HDA-Intel - HDA ATI SB        
                              HDA ATI SB at 0xfe020000 irq 23        
         1 [HDMI           ]: HDA-Intel - HDA ATI HDMI        
                              HDA ATI HDMI at 0xfdefc000 irq 19        
         2 [camera         ]: USB-Audio - USB camera        
                              USB camera at usb-0000:00:13.0-2, full speed     

The script has your HDMI device (IEC958), which is sound card 1, as switched OFF. It has no entries for your webcam sound device (presumebly a microphone) which is sound card 2. So I think we need to focus on sound card 0 which I assume is your nominal mother board sound device.

The script records your PC as having an ALC868VD audio codec. I note the following options can be specified in the ALSA-Configuration.txt file for an ALC861VD.

	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF OUT
	  6stack-dig	6-jack with SPDIF OUT
	  3stack-660	3-jack (for ALC660VD)
	  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
	  lenovo	Lenovo 3000 C200
	  dallas	Dallas laptops
	  hp		HP TX1000
	  auto		auto-config reading BIOS (default) 

What is tricky is how to apply this to your /etc/modprobe.d/sound file, given you have multiple audio devices. I assume, since you have the HDMI digital audio switched OFF, that you wish to apply this to sound card 0.

You could try modifying your /etc/modprobe.d/sound file to read like this

options snd slots=snd-hda-intel,snd-hda-intel
# NXNs.xHzNdX5ujM2:Radeon HD 3870 Audio device
alias snd-card-0 snd-hda-intel
# 5Dex.g56WiP30F+E:SBx00 Azalia
alias snd-card-1 snd-hda-intel
options snd-card-0 snd-hda-intel model=3stack-660-digout 

thats a guess on my part (it may not work). After making the change, restart your alsa sound driver with su -c ‘rcalsasound restart’ , enter root password when prompted, and test your sound.

If that fails, you could try replacing “3stack-digout” with 3stack, hp, auto, lenovo, 6stack-dig, one at a time, restarting alsa after each edit, and then test your sound quality as part of each attempt.

I also checked the alsa website for updates wrt the ALC861 and obtained the following result: Search results for ALC861 - AlsaProject from that I note there were a couple updates down between 1.0.16 and 1.0.18 of alsa. Hence you could consider updating your alsa to 1.0.18. I can provide you some rpm commands on how to do that Alsa-update - openSUSE (Note you need to send 6 commands and not just 3)

First of all, thanks for replying so soon and concisely. That was really nice and helpful :slight_smile:

This is the output of cat /proc/interrupts

           CPU0       CPU1
  0:        124          9   IO-APIC-edge      timer
  1:          0        310   IO-APIC-edge      i8042
  4:          0          6   IO-APIC-edge
  7:          0          0   IO-APIC-edge      parport0
  8:          1          0   IO-APIC-edge      rtc0
  9:          0          1   IO-APIC-fasteoi   acpi
 16:        504      25115   IO-APIC-fasteoi   pata_atiixp, ohci_hcd:usb1
 17:         49       7839   IO-APIC-fasteoi   ohci_hcd:usb2, ohci_hcd:usb4
 18:        880     204280   IO-APIC-fasteoi   ohci_hcd:usb3, ohci_hcd:usb5, fglrx[0]@PCI:1:0:0
 19:       1874      79226   IO-APIC-fasteoi   ehci_hcd:usb6, HDA Intel
 21:       2543     538630   IO-APIC-fasteoi   eth0
 22:       1532      89589   IO-APIC-fasteoi   ahci
 23:          2        724   IO-APIC-fasteoi   HDA Intel
NMI:          0          0   Non-maskable interrupts
LOC:     960830    1301059   Local timer interrupts
RES:     662991     459654   Rescheduling interrupts
CAL:    3370510    4689216   function call interrupts
TLB:       6494       7299   TLB shootdowns
TRM:          0          0   Thermal event interrupts
SPU:          0          0   Spurious interrupts
ERR:          0
MIS:          0

…and here’s the address given to dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a


When I modified the file /etc/modprobe.d/sound file, sound came up to be fine again, good quality, but still had these performance problems when using vlc.
I checked a bit and it looks more like a graphic problem, since it only happens when it goes fullscreen, and it goes smooth if I change the window manager to Kwin. So, it sounds to me like a compiz problem due to a bad performance of the ATI driver, I dunno if you can confirm me that :slight_smile:

Anyway, I’d be thankful if you can tell me the 6 commands needed for updating the alsa codecs, just to give it a try. I don’t mind to skip the compiz effects but I’ve become used to them

At least I can enjoy sound now so thanks for it :smiley:

the same problem as you. thank for others!

Ok, IRQ 19 and 23 are being used for your audio. One for the ALC861VD and the other for the HDMI. I don’t know which.

I took a look again at your script output:

tsalsa.txt - nopaste.com (beta)
and it appears you did not have a completely successful update of alsa, as I note:

Alsa driver: 1.0.16rc2        
dpkg path:           
Alsa utils: 1.0.18

hence could you again post the output of:
rpm -qa | grep alsa
rpm -q libasound2
so we can check what you have installed? I think you are missing alsa-driver-kmp-pae.

ok, from that I noted this:

usbcore: registered new interface driver snd-usb-audio
usb 1-2: SN9C103 PC Camera Controller detected (vid:pid 0x0C45:0x60AF)
usb 1-2: PAS202BCB image sensor detected

ACPI: PCI Interrupt 0000:00:14.2[D] -> GSI 23 (level, low) -> IRQ 23
hda_codec: Unknown model for ALC660VD/ALC861VD, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=1 (0x15/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0
ACPI: PCI Interrupt 0000:01:00.1** -> GSI 19 (level, low) -> IRQ 19

You can see your USB (mic maybe) being detected and snd-usb-audio kernel model identified as needing to be loaded. You can also see IRQ23 and IRQ19 being assigned for audio. It appears IRQ23 is your motherboard audio and IRQ 19 your HDMI, but I could have that reversed. I note the line " hda_codec: Unknown model for ALC660VD/ALC861VD, trying auto-probe from BIOS… " where you can see the auto probe for your sound settings taking place. Its possible that failed (openSUSE-11.0 has a bug in that autoprobing that affects some sound devices - I don’t know which). Hence when you assigned the model option to your /etc/modprobe.d/sound file, it may have addressed part of your sound problem.

vlc is a great player, but some cautions wrt it. Keep its volume around 20% or so, as if you go much higher, it brings distortion.

Compiz is known to cause problems with video … sometimes one can not even get video to show when 3D desktop effects are enabled. The workaround is typically to assign the “x11” driver for one’s multimedia player output video module, but one can get performance hits with that. If instead one selects “xv” as one’s multimedia player output video module, then performance is better, but “xv” is often not compatible with Compiz. (note I don’t use special desktop effects such as Compiz myself … the above is only from reading).

OK, I’ll put these in a new post. You have some of the apps installed, but some you do not.**

For your openSUSE-11.0 pae kernel, to update to the latest alsa version, you need to send the following zypper commands (reference ) from a gnome-terminal or kde konsole with root permissions (ie type “su” first) when your PC is connected to the internet:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
zypper install alsa alsa-utils alsa-oss alsa-plugins alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia/CODE

zypper install alsa-driver-kmp-pae

zypper rr multimedia

You may be told you have some of those installed already. You need to reboot your PC after sending those commands. 

Then test your sound and hopefully it is better.

The previous post provided information on updating alsa.

On openSUSE, one can typically get codecs for audio and video from either the Packman repository or the videolan repository. The two repositories do not work well together, and hence I find one should use one or the other, but not both. I typically install libdvdcss2 application from videolan, then disable that repository, and I use the Packman repository for my multimedia needs. There is guidance here for setting up repositories in one’s software package manager under openSUSE: Repositories/11.0 - openSUSE-Community I recommend only OSS, Non-OSS, Update and Packman repositories (repos). Just those 4 repos. No others. None. You can add others once you understand more the risks and problems that can arise with extra repos.

Once those repos are installed I recommend you go to yast > software > software management and mark xine-lib for removal (don’t apply it yet). Then mark libxine1 from Packman for installation. Then apply both settings at once. Then install libffmpeg0 from packman (which installs dependencies that give you most of the codecs you may need), vlc from packman (if you have not the packman version), w32codec-all (for more codecs), smplayer (which will install mplayer, … imho smplayer is superior to vlc in some respects ). You could also install libdvdread4 and libdvdnav (needed together with libdvdcss2 for dvd playback). The packman packaged kaffeine (not the Novell/SuSE-GmbH version) is also useful.

Good luck!

johnsunalley, if you have a sound problem, and if you need it fixed, then please start a new thread.

hey there, I followed step by step every command, unchecked the repos and installed the new software. I could upgrade to the latest alsa codecs and install the new software with no problems, but after rebooting I still have unstable sound… sometimes good, sometimes choppy.
I’m also experiencing some Motherboard issues right now, weird stuff, so I won’t be messing up too much with the system right now. (I really hope it wasn’t due to anything I messed with) :
I’m moving to Linuxmint since it was my main distro (I’ll try the kde edition now), and it seems much less complicated to me.
I’m really thankful for all the work here and very sorry for not being able to find a way to stick with this distro wich I think is really attractive, but not the one for me right now.
Sorry also if it seems like lost work for you oldcpu :shame: I learned a lot and I’ll keep trying with next versions of opensuse.

I view “Linux” as “Linux”. Enjoy your next distribution, and I hope it works well for you.