Low performance...

So i finally decided to ask here for help cause i don’t know what to do anymore… :expressionless:

Ever since i installed 11.3, its performance is horrible… Sometimes its worse than cluttered damaged windows XP… It takes forever to boot, sometimes even longer than Win7, and general performance is just bad… At first i thought it’s because of the graphics drivers, but i installed them later on and allthough better, its nowhere near what Ubuntu or 11.2 was… I tried watching a video, and the whole system hangs and video stutters when i do that (or runs slow mo, when audio runs normally), when i have multiple windows open it takes a second or so to switch between them, and even desktop cube animation doesn’t run as smooth as it did in 11.2… I don’t know what to do, whatever i tried (and it’s not much) it just doesn’t get better…

I do have desktop effects on, but in 11.2 i had them all on and it never ran any worse than without them, so that can’t be it… Especially since the whole system stutters and hangs whenever i have multiple windows open… Takes a split second to start moving any windows too…

I never had a linux system that ran so bad… Ubuntu and 11.2 SUSE booted extra fast, and when i was in the system everything ran smooth, even when i had 10 programs open…

Now, this is probably my doing, but i don’t know what i did exactly and i’m noob at linux so i can’t fix it…

Does anyone have an idea what could be wrong? Is there some command i can run at terminal so i can give you my system info or something?

I mean i can still use the system, but something is probably wrong when it does things even XP or win7 didn’t do… Even panel crashed when i was setting it up… That can’t be good… :expressionless:

I don’t have a high end system, but as i said, all other linux distros worked extremely fast…

So, can someone please tell me what i’m doing wrong? And if i can fix it without reinstalling everything that would be great…

I would begin by disabling desktop effects. Just press alt > shift > F12 and your desktop should reset with effects off.

To see what resources are being used, click on the kickoff menu and type system monitor in the search field and launch it.

You mention 11.2 so did you do an upgrade or a new install? You also did not say what desktop.

will show if you have a process consuming CPU.

i did a new install…

also… where exactly is the system monitor? i didn’t quite get it, sorry… still too new :smiley:

So which Desktop? KDE or Gnome or something else?

System monitor can be found in manu System-Monitor-System Monitor

Or just open a console and type top

right forgot about desktop…

It’s KDE…

EDIT: found system monitor… doesn’t show any process that would use excessive amount of memory or cpu… everything seems normal… well to me, at least…

But still, the problem isnt’ showing up really when i don’t do anything, but when i play video, or have more windows open… and desktop effects tend to stutter… This never happened before…

Have you tried disabling desktop effects yet like I mentioned above?

Watch the system monitor while you do stuff. See if anything is maxing the CPU

Are you sure you properly installed the 3D drivers for your video? BTW which video card/chip and which driver.

I was thinking about video drivers… I have nVidia 9600GT 512 MB (so desktop effects shouldn’t be a problem, and weren’t before). I tried to install video drivers following a guide i found somewhere, either this forum, or wiki, but that failed, so later in my thread i was pointed the right way, then installed correctly… Maybe that’s how i messed up the system… But i don’t know how to check drivers (or even where they are for that matter), so i have no way of knowing if that’s what’s causing problems…

show us the output of (from a terminal)

zypper lr -d

CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

# | Alias                               | Name                                | Enabled | Refresh | Priority | Type   | URI                                                             | Service
1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                       |        
2 | download.nvidia.com-opensuse        | NVIDIA Repository                   | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.3/                        |        
3 | openSUSE-11.3 11.3-1.82             | openSUSE-11.3 11.3-1.82             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                         |        
4 | packman                             | packman                             | Yes     | Yes     |   90     | rpm-md | http://packman.jacobs-university.de/suse/11.3/                  |        
5 | repo-debug                          | openSUSE-11.3-Debug                 | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/  |        
6 | repo-non-oss                        | openSUSE-11.3-Non-Oss               | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/    |        
7 | repo-oss                            | openSUSE-11.3-Oss                   | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/        |        
8 | repo-source                         | openSUSE-11.3-Source                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |  

Here it is…

Vepar wrote:

> Here it is…

that looks reasonable, so my theory that you had pulled in conflicting
code is probably not correct…

well, i guess it is probably the wrong video driver or possibly your
install media is corrupt, did you:

  1. get your install image from http://software.opensuse.org/113/en ?
    (if not, then where?)
  2. check the md5sum of the downloaded iso?
  3. do this http://tinyurl.com/yajm2aq before install attempt?

if you answered “no” (or “don’t know”) to any of those then do step 3
now, and if it has errors see the following cites before you start over:

as for video, all of that stuff changed in 11.3 and you need to
(probably) have a look at these:


if those don’t fix you up: i may have missed it, but i don’t easily
see much about your hardware (except it ran XP and other pretty good,
at one time)…so, you might tell us about your RAM and CPU/speed…i
GUESS it is possible you are suffering from too little RAM and what
are seeing can be attributed to swapping…

you can boot from the install disk and run the “Memory Test” at the
bottom of the list…let it run overnight at least…

CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  1. I got that image from the official site…
  2. Didn’t do that, don’t know how…
  3. Did that, everything turned out ok…

My system:

AMD64 3000+ 2.2 Ghz (it’s overclocked, and i run 64 bit Linux)
1.5 GB DDR
3 GB Swap
nVidia GeForce 9600GT 512MB

Judging from my last experiences with Linux, this tends to be more than enough to run it smoothly, so that’s why i’m worried that i messed something up…

Or my processor finally started dying and is having difficulty caltulating 1+1… :\

I’ll test it out some more, try to find why it’s acting this way…

My system has same slowdown/freezing with nouveau video drivers after upgrade from 11.2 to 11.3. Switching to nVidia drivers cured it.
Another thread with same problem and solution is here: Another Nvidia Problem. Sllooow Performance.

I just saw this… Thx for the link, i’ll read it when i have the time, this seems to be more or less the problem i’m having… The only problem is, i installed nVidia drivers, and it’s doing that regardless… Maybe because i installed them twice, two ways, and they may be conflicting now and damaged my system. To make it better, i’m a complete noob, and don’t know where the drivers are, or how do i even see what i did. If this was in windows, i’d know what to do, where the drivers are, and i would have allready fixed it the moment the problem occured, but this is lunux, and i’m a noob… Oh well… In 11.2 i had nVidia control panel, but i can’t find it anywhere now, so this is probably caused by the drivers. Don’t know. If i can’t find a solution, i’ll reformat linux partitions and install anew.

Anyway, thx for the link! :good: