Low download speed in openSUSE 11 64-bit

Hi there!
I’ve installed new oS few days ago and it was…well quite good. My USB sound card works flawlessly, vga card also works fine, only my wireless RT2500 PCI card works kinda bad. At first when I connected to network, the download speed was low, but I read that it may be because of IPv6 service enabled. I turned it off in YaST and everything worked excellent. Day later download speed lowered and now it is around 7 kB/s. It’s not the matter of DNS, or something because download in LAN is as low as when I download stuff from the net.

What may be the cause of such problem?

I use kernel with built-in (?) Realtek RT2500pci drivers and use ifup to connect.

Thanks in advance.

Oh yeah, one more thing. When I lsmod it shows ip6_tables in modules list. Should it be there if IPv6 is turned off?


you can try this one, it solved my problem with the Realtek:

incredibly slow internet connection - openSUSE Forums


Nope. it didn’t work. Any other ideas?

any updates in this, I experience the same issue?

any updates on this, I experience the same issue?