Low boot resolution with proprietary Nvidia drivers

I’ve recently jump from the Ubuntu/Mint ship, and figured I’ve give a polished KDE distribution a shot. Of course I turned to OpenSuSE, and I love it so far. I’ve resisted KDE quite a lot since 4.x came out but it’s really come along. Much better than the (in my opinion) monstrous disaster that Gnome has become.

Anyways, on to my problem: I’ve installed the proprietary Nvidia drivers via the one-click-install shown in the wiki, and that worked great. But now my resolution at boot - that is the boot/loading screen, not my desktop - is shown at a very low resolution instead of my native resolution, like it was with OpenSuSE’s default open-source Nvidia driver, which I’m guessing is Nouveau. On Ubuntu, this was pretty easy to correct; all you had to do was edit /etc/default/grub and put your resolution there, and tinker with some other options so that instead of Plymouth trying to set its own, it just carries over Grub’s specified resolution. But I can’t seem to do that with OpenSuSE. For one, I don’t see /etc/default/grub, and more than that, I don’t think you guys use Plymouth. I could be wrong on that second point, though.

So, how can I change the boot screen’s resolution to my native resolution?

I’m using the latest Stable release (11.4) and latest Nvidia drivers. Other than that, the install is new.

Oh, and on a totally unrelated note: how long has the Japanese subforum claimed to be the Hungarian subforum? Those lying jerks.

Hello bugmenot101, here is a very small list of grub resolutions that you can set in your /etc/menu.lst text file:

#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x**301**=769  0x**303**=771  0x**305**=773   0x**307**=775
#      32K | 0x**310**=784  0x**313**=787  0x**316**=790   0x**319**=793
#      64K | 0x**311**=785  0x**314**=788  0x**317**=791   0x**31A**=794
#      16M | 0x**312**=786  0x**315**=789  0x**318**=792   0x**31B**=795
#     +-------------------------------------------------+
#  for more details and different resolutions see
#  http://wiki.archlinux.org/index.php/GRUB#Framebuffer_Resolution

Edit the menu.lst file in KDE by doing an Alt-F2 or menu Run command and type in:

kdesu kwrite /etc/menu.lst

In the grub menu, here is a typical entry (this is from my file and will not be just like yours:

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.4 - 3.0.3-0.5
    savedefault 0
    root (hd0,3)
    kernel /boot/vmlinuz-3.0.3-0.5-desktop root=/dev/disk/by-id/ata-Corsair_Performance3_SSD_1117810101000341020B-part4 resume=/dev/disk/by-id/ata-Corsair_Performance3_SSD_1117810101000341020B-part2 splash=silent quiet nomodeset showopts **vga=0x346**
    initrd /boot/initrd-3.0.3-0.5-desktop

Notice the vga=0x346 (1900x1200) which I set in Bold (but which is not really in bold) to stand out. Edit this number to match one of those in the resolution list or change the entry to vga=ask then, grub will stop and display a list of video numbers supported by your monitor and video card… Write down the ones you like and reedit the menu.lst file to add the one you want.

Thank You,

No good. I didn’t see a change in my resolution. Though I’m assuming you meant /boot/grub/menu.lst, since there is no /etc/menu.lst on my system. I think it’s strange that we’re to edit menu.lst directly. Does OpenSuSE still use legacy Grub? Either way, the resolution didn’t change either at grub or at the boot screen. This is after using hwinfo to probe for appropriate framebuffer, uh… number things. :sarcastic:

Yes. Grub Legacy
You can manage the bootloader from Yast > System > Bootloader

  1. Backup current /boot/grub/menu.lst

  2. Fiddle if you must

But if it’s booting OK and you have a working nvidia driver, I’m not sure I’d worry.
I’m not exactly sure what you want to change anyway. Are you meaning the menu itself?

No, I don’t mean the menu. I just meant that, at least when using Ubuntu, there was a little workout to Nvidia breaking the boot screen resolution that involved changing Grub’s resolution. If you forced Grub to display in your chosen resolution, you can make Plymouth use that resolution instead of asking the Nvidia driver to set one itself.

The problem isn’t Grub’s resolution at all. It’s not like I expect that to be in high definition or anything. But the boot screen - the green loading screen you get before logging in or getting the KDE splash screen, where things like dbus and modules load up - is displaying at about 1024x768 when I want it to display at 1440x900. Using Nouveau there wasn’t a problem and the screen displayed at native resolution. But with Nvidia’s drivers the resolution is pretty terrible.

I know this isn’t a big issue at all. It’s just looks, and those don’t really matter too much. I suppose the biggest inconvenience this causes is that the virtual terminals (or whatever those tty terminals are called) are also displayed at an extremely low resolution. The Ubuntu workaround also fixed those. It’s all about setting the framebuffer’s resolution, and how Nvidia breaks that somehow.

I know this isn’t a big issue at all. It’s just looks, and those don’t really matter too much. I suppose the biggest inconvenience this causes is that the virtual terminals (or whatever those tty terminals are called) are also displayed at an extremely low resolution. The Ubuntu workaround also fixed those. It’s all about setting the framebuffer’s resolution, and how Nvidia breaks that somehow.

Try adding the following kernel parameter to your menu.lst entry (and leave the vga=parameter as is).

video=1440x900

I don’t have nvidia hardware, but I can alter my splash (framebuffer) resolution with this approach.