Loud fuzzy noise when speaking into any microphone

Hi all,

I installed openSUSE Tumbleweed on my laptop today, because I’ve been using Manjaro on it until now and suffering from a problem where, when I record my voice with GNOME Sound Recorder or speak to someone over the internet with either the laptop’s built-in microphone or the speaker in my Apple Earpod earphones, its comes through as a loud “fuzzy” or “static-y” noise that drowns out my voice.

On my previous Manjaro installation, I tried a tool called Noisetorch to try to eliminate the fuzzy noise, but the best it did was to stop the noise only when I wasn’t speaking; the moment I ever spoke, the fuzzy noise would play on top of my own voice and drown it out again.

I heard from a colleague that this was a known problem with Manjaro, so I switched to openSUSE Tumbleweed to try to fix things, but to no avail, as I still suffer from this problem when I record my voice with GNOME Sound Recorder on my openSUSE Tumbleweed installation. (I’ve not tried speaking to anyone over the internet on openSUSE yet.)

Whilst Googling things, I came across “/usr/sbin/alsa-info.sh”, which I understand can be used to diagnose a computer’s sound card setup. But after running it, I’m struggling to understand the results, so I was wondering if you could help? My report can be found at: http://alsa-project.org/db/?f=0f007fdd08c6b96a85acada2ceff134df52db214

Also, I’m generally rather lost as to how to diagnose this problem now, so I was wondering if you had any other thoughts that might allow me to get unstuck?

Thank you in advance.

Have you tried adjusting the mic boost down? Did you ensure that one mic is muted?

The graphical “easyeffects” utility may be of help with adjusting the sound in this situation perhaps (just speculation as I’ve never used it)…

In my experience, the vast majority of times when this occurs, it is due to an inappropriate setting either at alsa mixer level, or at pulse audio level. More often the former than the latter but it can be both.

The most useful part of that script output, initially, is it provides an indication of your mixer settings for recording.

**Simple mixer control 'Mic',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: **Playback 0 [0%]** -34.50dB] [on]
  Front Right: **Playback 0 [0%]** -34.50dB] [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 **[0%] **[0.00dB]
  Front Right: 0 **[0%]** [0.00dB]
  Front Right: Playback 0 [0%] -34.50dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 63** [100%]** [30.00dB] [on]
  Front Right: Capture 63** [100%]** [30.00dB] [on]
**Simple mixer control 'Auto-Mute Mode',0**
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
**Simple mixer control 'Internal Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 2 **[67%] **[20.00dB]
  Front Right: 2 **[67%] **[20.00dB]

I note the** Simple mixer control ‘Mic’ **Playback at 0% … This should not add noise, but it should thou mean you get no confidence building feedback in your speaker or earphones that your mic is working when you record.

I note you have the Mic Boost set to 0%. I typically have minimal success when I try to record at 0% Mic boost. Try raising that to ~66% (but not 100%).

I note you have the mixer control capture set to 100%. In my experience that is a bad idea. Typically it causes a ton of noise when one does that. Try lowering that to 66%.

I note you have the ‘auto-mute’ disabled. This may not be an issue, but try setting that to ‘enabled’ (AFTER fixing above two items) and see if that makes a difference. If no difference then set back to disabled.

I note the ‘internal Mic boost’ at 66%. This should be good. Worst case you could try raising it to 100% but my guess is 66% is a superior setting.

Also , once those are set (which are ‘alsa’ level, and can be adjusted with alsamixer app (or amixer for command line people like me), launch pulse audio volume control (pavucontrol) and check the recording tab for recording levels. That too can be an issue. Further since pulse audio will allow one to assign audio devices (such as a mic) on a per application basis, ensure the mic you are trying to record from is properly selected in ‘pavucontrol’ for the application you are using to record.

Try the above … playing with different settings and let us know how it works.

Again , my experience is the vast majority of times, recording is due to bad alsa level (mixer) or pulse audio settings being incorrect.