Lots of sound problems

I was having problems with sound on my system where some program like Audacity would screw w/the volume making it so loud that the volume control that is kmix couldn’t do anything about it. I read somewhere that I should install pavucontrol to give better control. It did give me better control, but now I’ve got sound problems all over the place. A minute ago I had problems where sometimes the sound in the media I played didn’t want to play. So I rebooted. Now it seems to only have one channel. If something is making a sound, none of the apps can play. Also the volume knob on my keyboard doesn’t work. it seems it only affects kmix, even if kmix isn’t running. In fact, closing kmix doesn’t help any of these problems.
How do I normalize the audio so that:

  • I get my other channels back (sound multiplex)
  • the volume doesn’t go everywhere on a whim
  • the multimedia keys on my keyboard work again

I’m running openSUSE 11.4 64-bit. I guess I have ALSA, but you know what? I don’t see much in the way of configuration applets for sound, so I’m not even sure how things are configured.

Start here
SDB:Audio troubleshooting - openSUSE

Wow, that was fast. Thanks!
Unfortunately, they seem to gloss over my problems. The pulseaudio resources don’t address this either, and the Phonon link is dead (the GUI crashes every time I try to exit it anyway). Let’s start with my multi-channel problem, since that’s what’s so annoying now. I run

$ speaker-test -Dplug:front -c2 -l5 -twav


Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Playback open error: -16,Device or resource busy

Not terribly surprising since I do have a sound playing, but just one, so it shouldn’t be enough to crowd anything else out.

That you reported there makes perfect sense.

The problem there is speaker-test does NOT use pulse.

But you are probably playing sound in another application with pulse.

Hence pulse has seized the audio device, and is not sharing it with speaker-test.

If you wish help here, you need to provide :

  • the EXACT settings you have applied in pulse audio (ie each and every pavucontrol setting)
  • the EXACT choices you had OTHER than those settings
  • the EXACT multimedia applications you were using and what codecs they were trying to play, AND their settings for their output audio mode

I provided some guidance in a blog entry on some pulse audio basics: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

I’m not a sound guru. And having never had to fiddle with on my systems, it’s left me uneducated in this area. @oldcpu though should pick up on this soon enough. Complications arise when there is more than one piece of sound hardware. Eg. Onboard device and a PCI card. It’s important that you select the default device in Yast > HArdware > Sound And also set that in the mixer too With kde you also have to go to the system settings for the kde desktop > multimedia section and set the prefered device in there too

Things are starting to come into perspective now:

  • Those problems I was having with kmix (being bypassed, keybd volume knob not working) were fixed by deleting the configuration files in my home directory. That’s not the first time I’ve had to do that. Maybe I should set a cron job to do that from time to time.
  • The problem w/the mutliplexing was not that, exactly, but one app, vlc, hogging the sound card at everyone elses’ expense. I find that odd, because in Tools|Preferences|Audio I had the Output module given as “default” (what decides what’s default anyway?) which always worked before, but now that I have it on “ALSA module” and “Use S/PDIF when available” and “default” for the Device (and what decides what’s the default device?) vlc plays nice again.
  • As for the problem of other apps highjacking the volume and taking it out of kmix’s control, that might be part of kmix’s config files getting corrupted. I hope that’s it, because otherwise, that volume problem sounds like bad division of labour among apps.

Thanks for your help, guys.

Glad to read that.

An application you could consider adding to provide more options for the output mode for vlc is the application vlc-aout-pulse. With that you can use pulse audio with vlc and hence better able to share the sound device with all applications using pulse audio.

Hmm… ok. I installed it. It seems to be a single, shared library. What does it do? One thing it might do is fix that problem I had. I put the vlc settings to their defaults and I’m still able to mix sounds.

I’m still curious as to how “default” sound modules and devices are chosen.

This is the information that I have:

oldcpu@corei7:~/computer> rpm -qil vlc-aout-pulse
Name        : vlc-aout-pulse                                                                                                                            
Version     : 2.0.1
Release     : 8.4
Architecture: x86_64
Install Date: Sun 22 Apr 2012 08:57:57 AM CEST
Group       : System/Libraries
Size        : 31600                                                                                                                                     
License     : GPL-2.0+
Signature   : RSA/SHA1, Fri 20 Apr 2012 06:25:12 PM CEST, Key ID 45a1d0671abd1afb                                                                       
Source RPM  : vlc-2.0.1-8.4.src.rpm
Build Date  : Fri 20 Apr 2012 01:55:43 PM CEST                                                                                                          
Build Host  : Patchouli                                                                                                                                 
Relocations : (not relocatable)
Packager    : packman@links2linux.de                                                                                                                    
Vendor      : http://packman.links2linux.de                                                                                                             
URL         : http://www.videolan.org/vlc/                                                                                                              
Summary     : VLC Audio Out for Pulse Audio
Description :                                                                                                                                           
Extends VLC with Pulse Audio Support for Audio Out
Distribution: Essentials / openSUSE_12.1                                                                                                                

… ie it provides vlc with pulse audio support.