Lots of games freeze shortly after loading

I’m using the Mesa driver and a Radeon R7 370. My problem is that a lot of games I have (in Steam) will seem to load fine, but will just freeze after a minute or two. Sound continues to play, and I’m able to alt-tab out of the game and kill the process. I’m using the Plasma desktop environment. Steps I’ve taken to resolve/troubleshoot:

Enable/disable DPM
Switched between the version of Steam in Tumbleweed repos and in Games:Tools repo
Enable/disable compositing
Running the games from bash instead of directly in Steam

…and various other little things. I have noticed dmesg errors that mention segfaults in si_shader which might be a clue? Also, this seems to happen more often in Unity-based games. In fact, very graphically intensive AAA games that do not use Unity (such as Shadow of Mordor) seem to work fine.

The only other thing I can think of is that I have xf86-video-ati installed as well as xf86-video-amdgpu. Surely this is a conflict?

Any help would be gratefully received as I’m tearing what’s left of my hair out over this!

Hello! Have you solved this problem? I have it too, AMD RX 560. Wine games, like The Witcher or Heroes 5 work Very Fine!

But XCOM (2012) from Steam, or any other with Better graphics, freezes after 3-5 minutes. Suond is continuing, but monitor fall in No signal¨ state.

Are you on Tumbleweed? Nothing I tried helped, but it eventually resolved itself. I guess an update to something eventually fixed it. Unfortunately I can’t say what, sorry. :frowning: