Lost web browser & email client after updates

Does that mean after doing
Unconditional update of system?

How is that done? I’ve only used Yast, do I use something else?

This is the QT UI of KDE, if you use Gnome GTK I don’t think this option is there


I hope you can see this image clearly.
There are some choices to fix dependencies, I have to study it more. Any suggestions? I don’t want to lose anything, but downgrades might be ok…
http://kde-look.org/content/download.php?content=156448&id=1&tan=2798896http://kde-look.org/content/download.php?content=156448&id=1&tan=2798896Download KDE-Look.org

In each case you want to mark the Deinstallation of…
Then try again

Ok, that’s updating now, 2075 packages to update! I’ll get back to you after. My fingers are crossed.

That didn’t fix anything, but on the bright side, it didn’t get any worse. lol!

Did you try

firefox -safe-mode

user@linux-fi3i:~> firefox -safe-mode
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).

Below: I found the first line someplace last night, but it didn’t make Firefox run - just didn’t see the “disabled” warning

user@linux-fi3i:~> export NSS_USE_SHARED_DB=enabled
user@linux-fi3i:~> firefox -safe-mode

The terminal feedback you are seeing is normal. I get the same, it’s always been that way.

Boot a live CD of 12.1 or 12.2 and try firefox in live session

report back

Ok, I’m in. Firefox works fine here.

So we can safely say your system has become somewhat borked
We did rule out user settings, because you tested a New user didn’t you.

I forgot, it’s 12.2, sorry about that

I haven’t tried that yet, must have missed that one.

Maybe time to move to 12.2?

Not really the answer you are looking for…

There are other brute force repairs I could suggest but they basically end up as if you did a clean install

Lucky I mentioned it

Well, I’ll need to upgrade in a few months or so anyway. I like to wait as long as possible so more bugs are squashed, but it has to be now, I guess. I just need to finish backing up things I should have backed up already. Anyway, thanks to all for the help!

Wake up people .In two months we will have new release (12.3)
12.2 is already as stable as it gets or atleast it is for me :slight_smile:

I created a new user, and everything I tried works! Still, being that 12.1 is getting old, I’ll be upgrading anyway. Still, this was a good lesson for me. I’ll try this idea first when something really weird happens. Thanks again!

You are welcome