Lost VirtualBox audio after upgrading to Opensuse 12.3

After upgrading to Opensuse 12.3, I no longer had audio to VirtualBox 4.2. I upgraded to VirtualBox 4.3, but that didn’t fix the problem. The VBox configuration has the Host Driver as PulseAudio and the Controller as Intel HD Audio. When I start the VM I get a warning SUSE Paste

The VBox log shows:

00:00:00.774052 Audio: Trying driver 'pulse'.
00:00:01.034691 Pulse: Audio input/output stopped!
00:00:01.034718 Pulse: Failed to connect to server: Connection refused
00:00:01.034811 Audio: Initialization of driver 'pulse' failed, trying 'oss'.
00:00:01.034853 OSS: Failed to open /dev/dsp for ADC (No such file or directory)
00:00:01.034870 HDAcodec: can't open in fmt(freq: 44100)
00:00:01.034879 OSS: Failed to open /dev/dsp for DAC (No such file or directory)
00:00:01.034884 OSS: Failed to open /dev/dsp for DAC (No such file or directory)
00:00:01.034890 HDA: WARNING: Unable to open PCM IN!
00:00:01.034892 HDA: WARNING: Unable to open PCM OUT!
00:00:01.034895 Audio: Using NULL audio driver
00:00:01.034903 VM: Raising runtime error 'HostAudioNotResponding' (fFlags=0x0)
00:00:01.034908 Console: VM runtime error: fatal=false, errorID=HostAudioNotResponding message="No audio devices could be opened. Selecting the NULL audio backend with the consequence that no sound is audible"

I have audio on the host side but don’t know how to troubleshoot this problem. Any suggestions will be welcomed.

I forgot to mention that the client VM is Windows 7.

Under Audio settings try to change the Host Audio Driver to the ALSA Audio Driver.

After dealing with some more pressing issues, I tried the ALSA driver and it worked. Thanks.