Lost Username / Password - HELP!

Hi all,

just installed openSUSE 11 and I can’t log in. I clearly remember my username and PW, but I can’t log in. Even if I try to login as root, (Not in the console), I can’t log in.

Is there a way to get back my username? Because I’m quite sure I know the PW. Or could it be that the problme has something to do with the fact that I coulden’t use the GUi on install? (I only had the Blue background kind of thing)

Thanks for all help in advance,


It would be simpler for you just to install again, it doesn’t take long.

This might do it:
How To: Recover the Linux root password

Once you can log in as root, you can alter your user credentials. Then reboot as yourself.

@caf4926: That’s what I thought. Now I have installed openSUSE 11 again, this time I wrote down my username & password and I still can’t log in. This has to be a problem with openSUSE 11. I have absolutely no idea what’s wrong.

Here are some more details about the installation & hardware:

-openSUSE 11 Internet Installation
-Toshiba Protege R100 (HCL/Laptops/Toshiba - openSUSE)

Thanks for all your help!


you could just try 10.3
then try an upgrade

KDE4 is experimental. Was that with KDE4?

@caf4926: Is there an internet installation of openSUSE 10.3 available? I can only use the internet installation because the R100 doesn’t have an internal cd/dvd drive.

@swerdna: Yes, that happened with KDE 4.0 but second time I used Gnom and that would only start to a green background screen and then do nothing. I haven’t tried KDE 3.x.

Thanks for all the help guys!


Intuition says (and who knows what that means) says to do a text install rather than a GUI install because perhaps it’s getting hung up on the video settings. I wonder how/if you can do a text based install and perhaps get right to the end, where you might then be able to log on in console mode and then fix the video.

Another thought associated with avoiding strife from video: if you type the numeral 1 when the Grub menu starts, and then press enter, it will boot to a console for root-only called runlevel 1. Can you log onto that (assuming you haven’t tried runlevel 1)? If you can you might be able to think about fixing the GUI/video from there (if it is the video).

Of course, these won’t do a thing if my intuition is wrong, which is highly likely. Perhaps try out item 2 as a very easy thing to do.

I think suse 11 included icewm with the installation. Can you please check if it is in the selection box and boot from there if it will give you the gui.

Opps apologies, just realize you can’t even reach the login screen.
Before another reinstall happens, try swerdna’s text boot using runlevel 1 or maybe runlevel 3 when there is a prompt for a user login in runlevel 1 you have to login as root as mentioned in swerdna’s post. If you use runlevel 3 you can login as the user and can su to become root and maybe try to run the command sax2 -r -m 0=vesa (0 is zero not o). If you pass the annoyances in runlevel 3 do a command init 5 if you reach init 5 if you are using kdm as your display manager type kdm at the promt to start the gui interface of the login screen, or you can use, startx to directly boot to your disktop as root

@conram: The only problem is that when I enter the console, the bottom part of it is “under” (wrong resolution) the screen, so I can’t see what I’m typing.

Thanks again for your help!