Lost sound trying to install Skype

On 2013-06-26 12:36, mikejd wrote:
>
> robin_listas - tried the CLI “rcalsasound restart” as you suggested and
> it didn’t work. Thanks anyway.

Any error? Anything in the logs?


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

When sound is not working , pulse audio has files open.

When sound is working, pulse audio appears not to be even running.

That suggests to me your PC has pulse audio configured incorrectly upon boot for the applications you are using on your PC.

When your PC sound is working, if you go to YaST > Hardware > Sound > Other > Pulse Audio configuration > Enable Pulse Audio > OK … does your audio still work ?

Also, when your sound does not work, is it ONLY Skype that does not work, or is it sound in all applications that does not work ?

When your PC sound is working, if you go to YaST > Hardware > Sound > Other > Pulse Audio configuration > Enable Pulse Audio > OK … does your audio still work ?

Also, when your sound does not work, is it ONLY Skype that does not work, or is it sound in all applications that does not work ?

When sound is working ‘Enable Pulse Audio’ is checked OK.

When sound is not working it is all applications.

Please confirm in your applications (such as Skype, vlc, smplayer … ) that you have ‘pulse’ selected as the sound 'output module".

For example, smplayer:
http://thumbnails108.imagebam.com/26249/a7fc97262482534.jpg](http://www.imagebam.com/image/a7fc97262482534)

This confuses me. As does the output of an ‘lsof’ command . ie

Again, when sound is working, please provide output of


 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

There should be pulse entries there, and your previous post had no entries. Your previous post had:


mike@dhcppc2:~> lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

 lsof: status error on /dev/dsp*: No such file or directory
 lsof: status error on /dev/audio*: No such file or directory
 lsof: status error on /dev/mixer*: No such file or directory

Not having pulse entries there when sound is working is inconsistent with the diagnostic script and it is inconsistent with your above quote, and so I need you to confirm this.

I want to see the output of that command when sound is working.

Output:

mike@dhcppc2:~> lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
lsof: status error on /dev/dsp*: No such file or directory
lsof: status error on /dev/audio*: No such file or directory
lsof: status error on /dev/mixer*: No such file or directory
COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
pulseaudi 8034 mike  mem    CHR  116,4          62679 /dev/snd/pcmC0D0p
pulseaudi 8034 mike   20u   CHR  116,7      0t0 62682 /dev/snd/controlC0
pulseaudi 8034 mike   21u   CHR  116,4      0t0 62679 /dev/snd/pcmC0D0p
pulseaudi 8034 mike   28u   CHR  116,7      0t0 62682 /dev/snd/controlC0
pulseaudi 8034 mike   33u   CHR  116,7      0t0 62682 /dev/snd/controlC0
pulseaudi 8034 mike   39u   CHR 116,18      0t0 62733 /dev/snd/controlC2

It appears that pulse audio is now working.

another example with selecting ‘pulse’ in vlc:
http://thumbnails104.imagebam.com/26255/83bf11262544397.jpg](http://www.imagebam.com/image/83bf11262544397)
.
.
and another example with selecting ‘pulse’ in Skype :
http://thumbnails107.imagebam.com/26255/065824262544695.jpg](http://www.imagebam.com/image/065824262544695)
.
.
Please ensure you have pulse selected in those apps.

OK, thanks. Then to confirm your original post did not have the outputs reversed, next time you boot and the sound is not working in ALL applications (and not just in one app) please send the command:


lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

and provide here the output.

Thanks.

mike@dhcppc2:~> lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
lsof: status error on /dev/dsp*: No such file or directory
lsof: status error on /dev/audio*: No such file or directory
lsof: status error on /dev/mixer*: No such file or directory
COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 3788 mike  mem    CHR 116,13          5024 /dev/snd/pcmC1D3p
pulseaudi 3788 mike   28u   CHR  116,9      0t0 4996 /dev/snd/controlC0
pulseaudi 3788 mike   33u   CHR  116,9      0t0 4996 /dev/snd/controlC0
pulseaudi 3788 mike   39u   CHR  116,3      0t0 6412 /dev/snd/controlC2
pulseaudi 3788 mike   50u   CHR 116,18      0t0 5029 /dev/snd/controlC1
pulseaudi 3788 mike   51u   CHR 116,13      0t0 5024 /dev/snd/pcmC1D3p

No sound in Skype, MPlayer, Kaffeine, Firefox browser or system sounds (KDE desktop launch). Don’t have any other sound apps as far as I know.

Open Yast>Hardware>Sound. first card is highlighted. Click ‘Other>>Play test sound’, speakers work. Click ‘Edit’ ‘Other>>Reset’ then restart sound card.

mike@dhcppc2:~> lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
lsof: status error on /dev/dsp*: No such file or directory
lsof: status error on /dev/audio*: No such file or directory
lsof: status error on /dev/mixer*: No such file or directory

Sound now working in Firefox browser, MPlayer, Kaffeine, Skype.

Pulseaudio is blocking the soundcard for all apps using ALSA.
You should install the package “alsa-plugins-pulse” to redirect ALSA apps to pulseaudio.
That should get rid of the problem.

(Or disable pulseaudio… :wink: )

Thanks wolfi323, alsa-plugins-pulse is already installed.

Could you post here the content of you PC’s /etc/modprobe.d/50-sound.conf file. Please confirm that the file is the same and does not change between when your PC boots (when sound does not work), and after you have gone to YaST and restored the audio.

I also note that the alsa-models.txt file has configuration options that be applied to an ALC662 (your PC’s sound device’s hardware audio codec) if things don’t seem to work properly. The list is here:


ALC662/663/272
==============
  3stack-dig    3-stack (2-channel) with SPDIF
  3stack-6ch     3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  5stack-dig     5-stack with SPDIF
  lenovo-101e     Lenovo laptop
  eeepc-p701    ASUS Eeepc P701
  eeepc-ep20    ASUS Eeepc EP20
  ecs        ECS/Foxconn mobo
  m51va        ASUS M51VA
  g71v        ASUS G71V
  h13        ASUS H13
  g50v        ASUS G50V
  asus-mode1    ASUS
  asus-mode2    ASUS
  asus-mode3    ASUS
  asus-mode4    ASUS
  asus-mode5    ASUS
  asus-mode6    ASUS
  asus-mode7    ASUS
  asus-mode8    ASUS
  dell        Dell with ALC272
  dell-zm1    Dell ZM1 with ALC272
  samsung-nc10    Samsung NC10 mini notebook
  auto        auto-config reading BIOS (default)

The problem is your hardware is not specifically mentioned, so one would need to try one at a time, restarting the PC between each item that is tested.

Still, it is an option we can try if further approaches do not work. To try this, one needs to edit the 50-sound.conf file (which is one reason why I have asked to see it).

/etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-hda-intel,snd-usb-audio

u1Nb.Cg7+jDYHCY5:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

NXNs.UtMRYeUD0j2:nVidia Corporation

alias snd-card-1 snd-hda-intel

wn1q.uejQFdF+_yF:Audio Adapter

alias snd-card-2 snd-usb-audio

This does not change after reset.

Thanks.

I am assuming that the speakers’ you refer to are not HDMI speakers. If they are, then my following suggestions are wrong.

I note your PC has an ALC662 and I note another user had a problem not long ago per this thread: https://forums.opensuse.org/english/get-technical-help-here/hardware/486313-no-sound-opensuse-12-3-since-upgrade-snd-hda-intel.html … but they dropped off the face of the earth and never tried following up after some initial suggestions did not pan out for them.

One thing you could try, is add your regular user to group ‘audio’ and then restart see if that permission change helps. My guess is it should not, as I have not read anything to suggest this is a permissions problem.

Under a speculative possibility that alsa and pulse audio are not communicating well, you could try to force a specific alsa mode upon boot, in the hope that mode will play nicer with pulse. To do so, lets start with the model option “auto” (from the list I provided in a separate post).

Try a hand edit to that /etc/modprobe.d/50-sound.conf file, so that it looks like:


options snd-hda-intel model=auto
options snd slots=snd-hda-intel,snd-hda-intel,snd-usb-audio model=auto
# u1Nb.Cg7+jDYHCY5:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel
# NXNs.UtMRYeUD0j2:nVidia Corporation
alias snd-card-1 snd-hda-intel
# wn1q.uejQFdF+_yF:Audio Adapter
alias snd-card-2 snd-usb-audio

restart and test. If it works stop testing and stick with what works. It may make things worse, in which case try another option in the list by replacing ‘auto’ with the next option in the 50-sound.conf file, saving, and restarting. Keep trying each one (no matter if it says asus, or levenovo, or some other vendor). Only try one at a time. After you have tried all, if none work, then remove that extra line so that you are back to where you started.

Tried editing 50-sound.conf as suggested but had no effect with auto setting.

Before going any further I happened to notice that the tool tray link to Kmix wasn’t working and tool tip said it couldn’t find the application. Checked it was installed - OK. Then had an idea to try a different desktop manager. Rebooted into IceWM and the speakers now worked in browser and Skype without having to do anything. Rebooted into KDE - no sound. So, is this in fact a KDE issue?

Its possible.

I’ve never gone and messed with KDE desktop multimedia settings myself.

But I know other’s have.

Once one goes down that path, if one retains their /home, then it can be impacted each time one updates the distro.

As noted, this has never happened to me as I do no touch those settings.

Sorry, but *which *application couldn’t be found?

Could you please post the exact message or provide a screenshot?