Lost sound in opensuse 12.1 for codec AD1884A

I have 12.1 version of OpenSuSE. After the installation, the sound was working for several months,
but a couple of days ago, I lost the sound. There is no sound both for user and for root accounts.
Yast section on sound used to call my sound controller as 82801JD/DO (ICH10 Family) HD Audio Controller.
I tried the following guide:
SDB:Audio troubleshooting - openSUSE
but I got stuck at the step 5 (“Add model to /etc/modprobe.d”). My file:
/etc/modprobe.d/50-sound.conf is:
options snd slots=snd-hda-intel
alias snd-card-0 snd-hda-intel
How do I figure out which model to add? The file /proc/asound/card0/codec#0
has the first line:
Codec: Analog Devices AD1884A
So I suppose my codec is AD1884A. The guide refers to:
But I don’t have /usr/src/linux-… directory on my computer.
Alsa-Configuration file on http://hg.alsa-project.org/ says “AD1884 N/A”…
Where can I find the name of “model” parameter for AD1884?
Is there any other way to test and set up the sound?
Thanks a lot!

OK, problem solved. I installed alsa firmware package, and rebooted the machine. The sound came back, although
I am not sure it was because of alsa firmware or something else.