Lost sound in 11.2

When I first installed this version the sound worked fine without me having to do anything. I then started playing with the KTTS - KDE Text-to-Speech System and ZoneMinder. Ever since the sound has gone.

Yast gives the following:
82801EB/ER (ICH5/ICH5R) AC’97 Audio Controller
Configured as sound card number 0
Driver snd-intel8x0

Yast>Hardware>Sound>test> generates a sound. Amarok, Skype don’t

I don’t use Skype. In the case of Amarok, check what you have selected for an audio backend, and if the option is available, see what happens when you change the backend.

Are you a KDE or gnome user?

I use KDE
Skype now works. I looked at some other sound problems on the forum and worked through them. One of them got Skype to work and Amarok to recognize the sound card, but not play anything. When I go into the Amarok configuration and test the sound it works but does not play any of the music in my playlist.

Just yesterday I solved something alike, same phenomena. From what it looked like, the ‘speech-dispatcher’ grabbed the card, not letting amarok to use it. Stopping the speechd in Yast - System - runlevel editor solved matters. The owner of the machine has not reported new issues today, sound is working normally now.
I’ve read some posts yesterday where someone could only get it to work properly by making himself a member of the ‘audio’ group.

In order to play sound, amarok typically uses an audio backend.

In the KDE3 version , this would be a selection in Amarok. I think in the KDE4 version one needs to ensure that they have the appropriate backend setup in KDE4 desktop (which Amarok will then use), and that is done in KDE > Configure Desktop > Multimedia.

Note if your PC has multiple sound devices you need to ensure that the priority of sound devices which you will see in YaST > Hardware Sound, is also configured similarly in KDE > Configure Desktop > Multimedia.

And note that Linux does not share audio devices well between multiple applications (at the same time) unless one has the alsa-api selected (which works for some hardware) or one has pulse audio enabled and properly configured.

Good luck.

Actually, it happened to me too when I updated few days ago. What happened was that name of the drivers changed, why - dunno, but also, PCM audio volume gone to 0 every time I booted system.
Interesting is that in mixer, PCM showed max while in YaST sound, was zero. Setting in YaST to max, sound appeared.

then I made another update, and problem disappeared…

I shut the machine down and restarted now Skype does not work again. I did this KDE > Configure Desktop > Multimedia, still nothing. I did to set up the machine to talk with KTTS - KDE Text-to-Speech System. Do you think this has stolen the card and not sharing? How do I uninstall this?