Lost plasma window for desktop folder

My mistake i clicked on the “X” of the plasma window on the screen that showed all the files in my desktop folder. Now I am unable to find how to restore or recreate this view on my desktop. Thank in advance for the help.

I think it is right click on desktop, add widgets, and drag and drop the one called ‘folder view’. Then you can use the little wrench and set the folder view to whatever folder you need it to be. Though I am not on kde right now so my directions could be a little off.

Yes, that’s basically it

Yep, that did for me. Thank you very much.

Now right click the desktop and > Lock Widgets

So it doesn’t happen again

If you’re like me and frequently edit files in there, you can try to modify the widget options to hide backup files used to revert changes…

But, it’s not working on my openSUSE12.2/KDE4.8.5(Rel2), I submitted a bug report long ago which has been unresolved.

It did work fine for me in previous (lower version) KDE.