lost opensuse personal preference after upgrade

After upgrading my system with latest from the opensuse 11.1 repository and other standard non-oss repositories on Oct 9, 2009, I realized that I’ve lost desktop look and feel preferences after a restart. When I run ControlCenter>Appearance, I get a dialogbox with the following message and I can no longer modify the settings.

Unable to start the settings manager ‘gnome-settings-daemon’. Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with Bonobo, or a nom-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.

Could someone tell me how to fix this problem or give some insight? I’ve encountered it a few times before and solved it by reinstalling my opensuse 11.1. But I’d like to try to solve this without having to do it again. If possible!!!

Thanks in advance.

as a follow-up to this posting. I solved the problem by upgrade to Gnome 2.26. GNOME/2.26 - openSUSE