Lost notification sounds in KDE

oS 13.2 64-bit, KDE 4.14.9, desktop system, 2.1 speakers connected to the motherboard’s green line-out jack.

The mobo has HDMI out, unconnected. Video is a dedicated Nvidia GTX card, with HDMI por connected through an HDMI-DVI cable to a DVI monitor. Another monitor is connected directly to de card DVI port.

Since some days ago (perhaps a week or two) notification sounds are inaudible/not playing. There has been some problems a couple months ago with audio on steam and/or scummvm that I messed around to “fix”, mainly disabling and later re-enabling pulse-audio IIRC.

AFAICT all other audio works (sound tests, video playback, youtube, steam, etc.). Only exception are notifications AND Amarok.

Amarok won’t start mp3’s nor ogg’s (don’t have other formats).

Hardware is very common onboard HDA:

# hwinfo --sound
13: PCI 1b.0: 0403 Audio device                                 
  [Created at pci.328]
  Unique ID: u1Nb.udnV7GR60l7
  SysFS ID: /devices/pci0000:00/0000:00:1b.0
  SysFS BusID: 0000:00:1b.0
  Hardware Class: sound
  Model: "Intel Lynx Point High Definition Audio Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x8c20 "Lynx Point High Definition Audio Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8576 
  Revision: 0x05
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xf7310000-0xf7313fff (rw,non-prefetchable)
  IRQ: 46 (2379 events)
  Module Alias: "pci:v00008086d00008C20sv00001043sd00008576bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown

22: PCI 100.1: 0403 Audio device
  [Created at pci.328]
  Unique ID: NXNs.Z4Osc+HvcGB
  Parent ID: vSkL.xltNQFyR_DB
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.1
  SysFS BusID: 0000:01:00.1
  Hardware Class: sound
  Model: "nVidia GK107 HDMI Audio Controller"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0e1b "GK107 HDMI Audio Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8439 
  Revision: 0xa1
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xf7080000-0xf7083fff (rw,non-prefetchable)
  IRQ: 17 (619 events)
  Module Alias: "pci:v000010DEd00000E1Bsv00001043sd00008439bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)


Index     Model
0  Lynx Point High Definition Audio Controller
1  GK107 HDMI Audio Controller

Card 0 is set as main.
PulseAudio support is enabled.

Volume tab show master/PCM/Front/Central/Surround volumes between 90 - 100%, line boost at 33% and the rest at 0.

Volume test works OK.

KDE System Settings>Multimedia>Audio & Video settings

Audio reproduction preferred device - Internal analogic audio (same setting for notifications, music, video, etc.)
Audio hardware settings - GK107 HDMI profile OFF, Internal audioo profile ANALOG STEREO OUT connector LINE-OUT front left/right test OK.
Infrastructure - Gstreamer for Phonon 4.8.0

PulseAudio Volume control show same configurations of system settings.

Gstreamer/gstreamer_0_10 packages installed are from packman repo.

Amarok 2.8.0 is from oS update repo, but it should at least play oggs, IINM.

Any ideas?

kmix - right click - select master

Is the built in audio selected there?

Yes, forgot to mention that, sorry.

Main channel is “Internal Analog Stereo Audio”, which is also the only option under “playback devices”. This “current mixer” drop-down menu has “playback devices”, “capture devices”, “playback sequence” and “capture sequence” listed, but only "playback devices has the analog audio entry,the other three are empty.

I’m lost, really, even more considering that amarok is mute too. I’ve switched amarok to the packman package but it’s the same, it won’t even start any mp3 or ogg. It worked some weeks ago.

I also switched to the packman packages, as some libs when updated switch to kde or update repo, but no difference.

Check sound settings in KDE

Also assuming you run pulse try pavucontrol maybe a the desktop setting (setting when sound from desktop is running) is not set correctly

I did (see post #1), all seems OK. In KDE settings even the front left/right audio test works. Pavucontrol also checked, all settings seem OK.

What is curious is Amarok also not playing sounds. Kaffeine and smplayer (with mpv) play audio files OK, however.

Idea - I’ll try a new user and report back.

With a new user there is sound, both notifications and Amarok. Why, oh why?

If new user works problem is in the configs in you home.

Since the broken apps all use the KDE sound system it probably is some where in that area. Does the sound work in the desktop setting sound??

Yes, the test works (the front left/right test, I mean).

I’ll check ~/.kde4,but there’s a lot of sound/audio/amarok related files, so I’m wondering if there’s a way to narrow it.

There are also some differences in ~/.config/pulse/xxx-default.source:

old user: alsa_output.pci-0000_00_1b.0.analog-stereo.*monitor*
new user: alsa_output.pci-0000_00_1b.0.analog-stereo

In old user home there’s also a .pulse-cookie file that doesn’t exist in new user’s home.

Also in system-settings the GK107 HDMI audio device status is:

old user: deactivated (greyed out)
new user: available but not the preferred choice.

edit: activating GK107 back in old user makes no difference, still no sound.

Not that many, actually. One of them, <old user>/.kde4/share/config/phonondevicesrc has 14 entries, <new user>'s is empty:


I copied this file to <old user> and restarted KDE session, still no sound.

General rule is that removing config files they will regenerate.

If m I’d logged into a termeinial as root would erename /home/theusername/.kde4 re log in top gui as self and see if that fixes it. if so the file problem is in there. But I don’t mind resetting the desktop to my liking again

OT, reseting everything is too extreme for me, my desktop is heavily customized, it take me hours (days?) to do it properly. I usually do this with a new install only, in this case my experience is that keeping previous kde configs is troublesome.

Back on track, it might be a gstreamer problem. When starting amarok in a terminal and trying to play a mp3 I get a lot of:

(amarok:6490): GStreamer-CRITICAL **: gst_element_get_state: assertion 'GST_IS_ELEMENT (element)' failed

(amarok:6490): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

Ill try clearing the gstreamer cache as suggested by wolfi in another thread and post back.

Or also downgrade gstreamer to version 1.4.

That worked! Thank you wolfi, gogalthorp and caf!

Just to mark as solved in the title.