Lost NetworkManager icon

Suse 11.1 KDE 3.5

NetworkManager worked just fine until I inadvertently deleted the icon from my panel (overly sensitive touchpad). I tried to restart it using “nm-applet” but of course since I was not connected zypper could not download the necessary software. There is no CD drive on this netbook so the only way I can install anything is via USB. Is there any way to restore the icon or connect the wireless?


For KDE 3.5, try restarting it with ‘knetworkmanager’, either via ALT- F2 or from terminal.

If NetworkManager (the underlying app) is not running, you may need to restart this as root with

rcnetwork restart

Thanks for the suggestions. Running NetworkManager seemed to have no effect but did not produce an error.

Likewise running rcnetwork restart appeared to work, reporting the shutting down and restart of the network. But I was still not connected and the icon was still missing. Attempts to restore the icon from the system notification panel also failed.

But then I rebooted and the icon showed up again and I was able to connect in the usual way.

Life is full of mysteries. Thanks again.