Lost korganizer calendar when updating KDE 4.95 to 4.10

I tried to update from KDE 4.95 to KDE 4.10 with no success - in particular, my desktop disappeared. I erased .kde4 and got a desktop, but I lost a lot of valuable settings. As a result, I went back to 4.95 and restored my .kde4 directory and .config directory that had been backed up 4 days ago. In the process, korganizer managed to lose all my calendar entries since last November. I assumed they would still be there (at least as of 4 days ago) as the restored std.ics in .kde4/apps/korganizer and the rc files in .config were current as of 4 days ago. Yet they are not there, though the older entries are. Is there some other file I need to restore that I am somehow missing that might have been corrupted in all the excitement? Might there be another place that a calendar was stored or another file that would identify it to korganizer? I rely on that calendar and am a bit desperate.


I forgot to mention that I did select the database appearing on the lower left of the screen. My recent entries are still missing.:frowning:

Did you restore the backup whilst being logged in? If so, remove the current ~/.kde4 and restore the backup whilst not being logged in as the user concerned.

I restored to a temporary directory, used the magickey-e to exit to a command prompt, logged into the account on the command line, renamed the existing .kde4 directory to .kde4last and moved the restored .kde4 to home. Should I have done this from root, found some other way to get to a non-graphic session, completely erased the existing .kde4, or some or all of the above?

You shouldn’t do that whilst the user is logged in. So from some other user’s account, or from the console.

So, I restored .kde4 and .config to a temporary directory, logged out of my account and logged into root. From root, I copied them to my account’s home directory. Still no luck. In fact, korganizer is still referencing a copy of std.ics under a different name that I created in .kde4 and linked to korganizer after my problems started and after the restore. This file does not exist in the restored .kde4. There is obviously another rc file of some sort elsewhere that I am missing. If I knew what it was, I could probably get my old calendar back. Right now, I have no clue.