Lost KDE Desktop Effects

Hi everyone
I am Running opensuse 11.4 (64 bit) KDE desktop with all the updates & proprietary ATI driver installed.
My processor is Athlon II X2 250 & motherboard is gigabyte MA785GPM-UD2H. I have 4 GB (2 +2) of DDR 2 RAM installed.
I have turned off automatic updating & usually update my machine once a week.
But just couple of days ago I had just updated my system and KDE desktop effects stopped working!!
I went to the Application launcher -> Configure Desktop -> Desktop Effects and everything was grayed out!! except for the following message
“Desktop effects are not available on this system due to the following technical issues:“

But, what technical Issue?? there was nothing else written!!

Googling for the issue has actually left me more confused; but I am still posting the content of my
~/.kde4/share/config/kwinrc file (in-case if it helps).

$Version]
update_info=kwin_focus2.upd:kwin_focus2,kwin_blacklist.upd:Blacklist-4.5,kwin_blacklist.upd:Blacklist-openSUSE-114,kwin_focus1.upd:kwin_focus1,kwin_on_off.upd:kwin_on_off,kwin.upd:kde3.0r1,kwin.upd:kde3.2Xinerama,kwin3_plugin.upd:kde3.2

[Compositing]
AnimationSpeed=3
Backend=OpenGL
CheckIsSafe=true
DisableChecks=false
Enabled=false
GLDirect=true
GLMode=TFP
GLTextureFilter=2
GLVSync=true
HiddenPreviews=5
OpenGLIsUnsafe=false
UnredirectFullscreen=true
XRenderSmoothScale=false

[Desktops]
Name_1=
Name_2=
Name_3=
Name_4=
Name_5=
Name_6=
Number=6

[Effect-BoxSwitch]
TabBox=true
TabBoxAlternative=false

[Effect-CoverSwitch]
TabBox=false
TabBoxAlternative=false

[Effect-Cube]
BorderActivate=9
BorderActivateCylinder=9
BorderActivateSphere=9

[Effect-DesktopGrid]
BorderActivate=9

[Effect-FlipSwitch]
BorderActivate=9
BorderActivateAll=9
TabBox=false
TabBoxAlternative=false

[Effect-PresentWindows]
BorderActivate=6
BorderActivateAll=7
TabBox=false
TabBoxAlternative=false

[ElectricBorders]
Bottom=None
BottomLeft=None
BottomRight=None
Left=None
Right=None
Top=None
TopLeft=None
TopRight=None

[MouseBindings]
CommandActiveTitlebar1=Raise
CommandActiveTitlebar2=Start window tab drag
CommandActiveTitlebar3=Operations menu
CommandAll1=Move
CommandAll2=Toggle raise and lower
CommandAll3=Resize
CommandAllKey=Alt
CommandAllWheel=Nothing
CommandInactiveTitlebar1=Activate and raise
CommandInactiveTitlebar2=Start window tab drag
CommandInactiveTitlebar3=Operations menu
CommandTitlebarWheel=Shade/Unshade
CommandWindow1=Activate, raise and pass click
CommandWindow2=Activate and pass click
CommandWindow3=Activate and pass click
CommandWindowWheel=Scroll

[Plugins]
kwin4_effect_blurEnabled=false
kwin4_effect_boxswitchEnabled=true
kwin4_effect_coverswitchEnabled=true
kwin4_effect_cubeEnabled=false
kwin4_effect_cubeslideEnabled=true
kwin4_effect_dashboardEnabled=true
kwin4_effect_desktopgridEnabled=true
kwin4_effect_dialogparentEnabled=true
kwin4_effect_diminactiveEnabled=false
kwin4_effect_dimscreenEnabled=false
kwin4_effect_explosionEnabled=false
kwin4_effect_fadeEnabled=true
kwin4_effect_fadedesktopEnabled=false
kwin4_effect_fallapartEnabled=false
kwin4_effect_flipswitchEnabled=true
kwin4_effect_glideEnabled=true
kwin4_effect_highlightwindowEnabled=true
kwin4_effect_invertEnabled=false
kwin4_effect_loginEnabled=true
kwin4_effect_logoutEnabled=true
kwin4_effect_lookingglassEnabled=false
kwin4_effect_magiclampEnabled=true
kwin4_effect_magnifierEnabled=false
kwin4_effect_minimizeanimationEnabled=false
kwin4_effect_mousemarkEnabled=false
kwin4_effect_presentwindowsEnabled=true
kwin4_effect_resizeEnabled=false
kwin4_effect_scaleinEnabled=false
kwin4_effect_screenshotEnabled=true
kwin4_effect_shadowEnabled=true
kwin4_effect_sharpenEnabled=false
kwin4_effect_sheetEnabled=false
kwin4_effect_showfpsEnabled=false
kwin4_effect_showpaintEnabled=false
kwin4_effect_slideEnabled=false
kwin4_effect_slidebackEnabled=false
kwin4_effect_slidingpopupsEnabled=true
kwin4_effect_snaphelperEnabled=false
kwin4_effect_snowEnabled=false
kwin4_effect_startupfeedbackEnabled=true
kwin4_effect_taskbarthumbnailEnabled=true
kwin4_effect_thumbnailasideEnabled=false
kwin4_effect_trackmouseEnabled=false
kwin4_effect_translucencyEnabled=true
kwin4_effect_windowgeometryEnabled=false
kwin4_effect_wobblywindowsEnabled=true
kwin4_effect_zoomEnabled=false

[PopupInfo]
PopupHideDelay=1000
ShowPopup=false
TextOnly=false

[Style]
BorderSize=1
ButtonsOnLeft=MS
ButtonsOnRight=HIA__X
CustomButtonPositions=false
PluginLib=kwin3_plastik
ShowToolTips=true

[TabBox]
HighlightWindows=true
LayoutMode=0
LayoutName=Default
ListMode=0
MinHeight=20
MinWidth=20
SelectedItem=0
SelectedLayoutName=Text
ShowDesktop=false
ShowOutline=true
ShowTabBox=true
SwitchingMode=0

[TabBoxAlternative]
HighlightWindows=true
LayoutMode=0
LayoutName=Default
ListMode=0
MinHeight=20
MinWidth=20
SelectedItem=0
SelectedLayoutName=Text
ShowDesktop=false
ShowOutline=true
ShowTabBox=true
SwitchingMode=0

[Windows]
ActiveMouseScreen=false
AutoRaise=false
AutoRaiseInterval=750
AutogroupInForeground=true
AutogroupSimilarWindows=false
BorderSnapZone=10
CenterSnapZone=0
ClickRaise=true
DelayFocus=false
DelayFocusInterval=750
ElectricBorderCooldown=350
ElectricBorderDelay=150
ElectricBorderMaximize=true
ElectricBorderTiling=true
ElectricBorders=0
FocusPolicy=ClickToFocus
FocusStealingPreventionLevel=1
GeometryTip=false
HideUtilityWindowsForInactive=true
InactiveTabsSkipTaskbar=false
MaximizeButtonLeftClickCommand=Maximize
MaximizeButtonMiddleClickCommand=Maximize (vertical only)
MaximizeButtonRightClickCommand=Maximize (horizontal only)
MoveMode=Opaque
MoveResizeMaximizedWindows=false
Placement=Smart
ResizeMode=Opaque
RollOverDesktops=true
SeparateScreenFocus=false
ShadeHover=false
ShadeHoverInterval=250
SnapOnlyWhenOverlapping=false
TilingDefaultLayout=0
TilingOn=false
TilingRaisePolicy=0
TitlebarDoubleClickCommand=Maximize
WindowSnapZone=10

By the way under the section [Compositing] I tried to do the following changes

Enabled=true

But nothing happens, & the value changes back to “false” automatically at the next reboot!!

Also tried

DisableChecks=false

but to no effect :frowning:

Also… one more thing, why does it say

Blacklist-openSUSE-114

at the first line???

Thanks in advance
emon_suse

Same problem here, except i`m using Tumbleweed under 64 bit, i have an Nvidia card and KDE 4.7
Can someone using either 11.4 or Tumbleweed but under a 32 bit system can provide feedback if KDE Effects are really working for them?
Here is a screenshot: http://imageshack.us/photo/my-images/37/snapshot6d.png/

Later edit:
emon_suse: out of curiosity i have disabled the functionality checks as you did and KDE Effects are working again :slight_smile:
Weird…

This is weird. This is the right value.
I haven’t updated my ATI machine for a couple days. I have to keep an eye on this.

Try to use compositor and see if it can restore desktop effects: compositor: quickly sets/unsets compositing (helps with fullscreen Flash on ATI)

Or use these commands:

kwriteconfig --file kwinrc --group Compositing --key Enabled --type bool true 
qdbus org.kde.kwin /KWin reconfigure

On 08/27/2011 10:56 AM, creatura85 wrote:
>
> Can someone using either 11.4 or Tumbleweed but under a 32 bit system
> can provide feedback if KDE Effects are really working for them?

desktop effects in KDE work here on a weak little one CPU netbook with
only 1GB ram which is capable of 64 bits, but has a 32 bit 11.4 installed…


DD
Caveat-Hardware-Software
openSUSE®, the “German Engineered Automobile” of operating systems!

Hi,

probably a reinstall of the ATI drivers will help…

HTH

Lenwolf

I don’t see any problem. You should indeed probably reinstall the ati driver.
Try the commands in this post to check the version and 3D rendering of the installed driver: trying to find XFree86
You can use atiupgrade to install the latest driver:

Hi again guys

I possibly couldn’t thank you guys enough :slight_smile:

I followed the instruction for reinstalling the ATI driver on the first link that
please_try_again suggested and now I can enable Desktop Effects again!

I only hope that driver won’t get broken on the next kernel update :stuck_out_tongue: (it probably won’t, cos that’s what the link said)

Thanks again guys
emon_suse

N.B. is there a way mark this thread as solved???

It should not. This version provides a service /etc/init.d/boot.fglrxrebuild that checks if the kernel module is present before entering X runlevel. If the module is missing (like after a kernel update), it runs the script /usr/bin/fglrx-kernel-build.sh to build the new module. Of course you should update the kernel sources together with the kernel, but it normally happens automatically.

That was some good stuff… I didn’t know that :slight_smile:

Thanks again
emon_suse