Lost internet connection, but can still reach windows host.

I use Windows 7 64, and OpenSuse 13.2 virtualized on VirtualBox, everything was working fine, but sometimes I lose internet from the virtualbox, i dont know why, but it comes back, but today, it dident!
So, i deleted the connection setting, and i added on which i fixed, but still nothing, I can reach my windows server application, but cant reach internet.
What is the problem?

Here is my route:

info@linux-4hrn:~> /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 1024 0 0 enp0s3
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 enp0s3

Here is a picture:
http://i.imgur.com/sUru7Ii.jpg

Update: This is what happens if i try to use automatic ip (DHCP)
http://i.imgur.com/rmM4G4k.png

And now when I reboot the VM on NAT instead of Bridge, it works, so what is the problem?

abdelouahab wrote on 04/16/2015 09:36 PM:
>
> Update: This is what happens if i try to use automatic ip (DHCP)
> [image: http://i.imgur.com/rmM4G4k.png]
>
>

Apparently a problem with Virtualbox on Windows. I’m afraid this is the wrong forum in this case. Your virtualized openSUSE sees a defunct NIC and reacts properly.

Uwe

Sounds to me like your described problem <might> be an ordinary networking issue, I wouldn’t jump to the conclusion that it’s a virtualization related issue yet. So, ordinary networking investigation procedures should be applied first…

When the problem exists (little chance to determine issues when working fine)

  • Ping outwards from the problem machine.
  • Ping inwards from the problem machine.
  • Inspect syslog for possible relevant entries
  • If network services are involved, probe them.
  • Maybe disable IPv6 (or IPv4) to force troubleshooting and routing using only one of the two versions of TCP/IP.

The reason why NAT would work is that your Guest isn’t connected directly to your physical network… It’s connected to a virtual network entirely within your machine only, and then connects through your Host to the physical network. In fact, if you have no reason to use bridged networking (typically to support incoming connections) you’d probably be happier using NAT for a variety of reasons.

TSU

Hi,
thank you for your replies.
The problem is that it was working, even with Bridged mode, but suddenly, it stopped, but still works when pinging or accessing the host webserver (as shown in the picture), and now, I use NAT mode, because this is the lonly one that works.
Thank you again.

Well, that is a very confusing statement.
If Bridge Mode networking has stopped, it can’t “still works…”

At that point you need to determine what works or doesn’t.
Ping both directions (in and out), by name and by IP address.

And, as I described even when in Bridge Mode it doesn’t matter that you can connect to any network locations on the HostOS, when you do that your network packets are routed internally on the machine and don’t pass through an external network interface.

If all your pings in and out to a <remote machine> fail, only then can you start to assume that something is amiss with your external networking interface and can turn your attention then to how it is configured (You’d then look at your Linux Bridge Device, possibly named br0 or virbr0).

TSU