Lost internal sound after upgrade to KDE 4.10 on openSUSE 12.2

Hello,

Right after upgrade I’ve lost all IN/OUT sound in my headset (earphones & microphone). Sound still works fine through my sound card via optical, but no sound or mic at all in the headset. I tried with root login, no sound either, so don’t think it’s a permission issue. When I move an audio stream from the HD Sound card to my Internal Sound, the PulseAudioVolumeControl shows a sound bar moving as if there is sound but I don’t hear anything in the earphones. When I use Skype with my headset, everything’s dead, no sound and no microphone working, the sliding bar for the mic doesn’t even move, so it’s completely dead.

I’ve deleted all sound cards, reconfigured them again, tried any possible combination of stream and volume control (PulseAudio and KMix) - nothing works. Tried the headset on another computer, it works fine, so it’s not the problem.

Has anyone experienced this? Any ideas how to fix this? Thank you very much.

I have not experienced this.

KDE-4.10 on openSUSE-10.2 is quite a move. I think openSUSE-10.2 nominally comes with KDE-3.5.5. There is always the possibility that a move from KDE-3.5.5 to 4.10 is too much. I assume you know that support for openSUSE-10.2 ended a long time ago - likely very very very very few people still use it, so to find someone else who has experienced this on openSUSE-10.2 will be difficult.

Edit - I also note your sig has openSUSE-12.2 … which suggests a typo in the title ? If so, the bad title could scare off potential help.

In case this is a configuration problem (that is not readily observable in pavucontrol that you note you checked) can you please with your PC connected to the Internet run this diagnostic script and post here the output URL that it provides after it is complete:


/usr/sbin/alsa-info.sh

Please choose the share/upload option when prompted when it is running. With that URL we can check the PC’s hardware and software configuration.

Sorry, my bad, of course 12.2, not 10.2!

oldcpu, please see the uploaded info at http://www.alsa-project.org/db/?f=8b68f2477af2e755c115f06222a3afef7adcce45

Thank you.

I changed the title. It now has 12.2.

For those not quite understanding what oldcpu and linuxiodoz are discussing, the original title of this thread mentioned 10.2. This was a typo. It is now 12.2 as intended.

And now it all works!!! It’s a miracle! Could it be the alsa-info script? Does it do anything? I swear I’ve wasted the past 2 days all for nothing. And now all of a sudden it all started working. Yeah, it must be the script! Thank you.

Glad to read it is working. :slight_smile:

IMHO it is unlikely the script. What is possibly more likely is a mixer setting was changed, or a pulse audio volume control setting was changed, or possibly an application (or even the desktop) had seized the audio device and was refusing to share it. So possibly a reboot killed the badly behaved application, allowing sound to work again ? … where this is all speculation on my part …