Lost home folder after trying to move it to a different partition; need help

I don’t think it is possible to get anything back, but I’ll try anyway. Sorry if this post is a bit strangely written, I’m actually just… no backups. None. I need help.
Before moving to openSUSE, I used Windows for a long time. I knew that I might have had troubles with moving to Linux, so I dual-booted. openSUSE chose to make the drive 35 GB large, and I didn’t change it because I didn’t think I would have problems with it.
So, I used openSUSE for some time. It was a good experience. But then I ran out of storage space. I couldn’t figure out how to expand the drive, so I thought, “Hey! Linux supports using a different partition for home, so why can’t I do that?” I followed the directions here. I used an 80gig partition on the same drive openSUSE was installed on, and I just mapped it to /home in fstab. I got everything set up, but wasn’t sure how to copy over the files so I just restarted and hoped it worked. Here’s the problem: I DIDN’T MAKE A BACKUP OF ANYTHING PAWDJJOIAWDHUSVBDNKJLIJ
Now, I start up, and I’m worried because I had auto-login or whatever it’s called enabled but it took me to the login screen anyway. I put in my password, it’s stuck on a black screen with the default cursor for a second or so. I expect Plasma to start, but it just sends me back to the login screen. I hit Ctrl+Alt+F4, enter my credentials, and I get something along the lines of… /home/samr not accessible; using / as home directory. ls /home, nothing. sudo mount /dev/sda4 /mnt/shouldbehome; ls /mnt/shouldbehome, nothing.
Someone please tell me if there is a way to recover from this, or if I just overwrote my entire home directory with an empty partition.

EDIT: I am happy… no… exuberant to announce that I am writing this on a working installation of openSUSE Tumbleweed with everything safe. *sigh* I just changed fstab back to use /@/home rather than the volume I set. I just can’t with myself after doing that, but this won’t happen again.

However, I do still have only 1MiB left on my drive. Not sure how to fix that, but at least I’ve learned and have the chance to try again with actual experience.

Welcome to the forum !!

So, it would be guesswork for folks on here to analyze next steps, without details.

You’d have to post the content of /etc/fstab before and after changes, plus your drive’s partition layout, for folks to assist in troubleshooting :+1:

But it’s great to read you worked it out yourself … sometimes that a great way to learn technology :slightly_smiling_face:

Show full output of

btrfs filesystem usage -T
btrfs qgroup show /

Just mounting the new partition at /home does not remove the data in the old it just hides the old and is used as the new mount point. To free space you need to delete the data from the old mount point.

The correct way is to mount the new driver on a folder under your home folder, instead of mount it directly on /home. That is, you should mount your new driver to, for example, /home/YOURACCOUNTNAME/DRIVERNAME.

The first command didn’t work no matter what I tried, but here’s the output anyway:

samr@samrmachine:~> sudo btrfs filesystem usage -T
btrfs filesystem usage: not enough arguments: 0 but at least 1 expected
samr@samrmachine:~> sudo btrfs qgroup show /
WARNING: qgroup data inconsistent, rescan recommended
Qgroupid    Referenced    Exclusive   Path 
--------    ----------    ---------   ---- 
0/5           16.00KiB     16.00KiB   <toplevel>
0/256         16.00KiB     16.00KiB   @
0/257          8.47GiB      8.47GiB   @/var
0/258         39.35MiB     39.35MiB   @/usr/local
0/259         16.00KiB     16.00KiB   @/srv
0/260         26.62MiB     26.62MiB   @/root
0/261        337.82MiB    337.80MiB   @/opt
0/262         14.87GiB     14.87GiB   @/home
0/263          4.04MiB      4.04MiB   @/boot/grub2/x86_64-efi
0/264         16.00KiB     16.00KiB   @/boot/grub2/i386-pc
0/265        132.00KiB    132.00KiB   @/.snapshots
0/266          7.33GiB     16.00KiB   @/.snapshots/1/snapshot
0/271         16.00KiB     16.00KiB   @/var/lib/machines
0/313          6.20GiB    315.73MiB   @/.snapshots/47/snapshot
0/314          6.41GiB     36.64MiB   @/.snapshots/48/snapshot
0/317          6.53GiB     31.55MiB   @/.snapshots/51/snapshot
0/318          6.32GiB    105.72MiB   @/.snapshots/52/snapshot
0/367          7.32GiB    205.54MiB   @/.snapshots/101/snapshot
0/368          7.33GiB     16.00KiB   @/.snapshots/102/snapshot
0/369          7.33GiB     16.00KiB   @/.snapshots/103/snapshot
1/0            8.76GiB      1.65GiB   <0 member qgroups>
255/271       16.00KiB     16.00KiB   <0 member qgroups>

Yes, I missed the /. It even quite clearly told you so.

btrfs filesystem usage -T /

It’s alright. I have figured out how to expand the size of the entire drive backwards, so it is now up to 100 GB. Thank you for trying to help, but it isn’t necessary anymore.