Lost Ethernet Connection - Opensuse 11.4 Tumbleweed - SOLVED

**Motherboard: **Gigabyte MA790XT-UD4P
Integrated NIC: RTL8111/81688 PCI Express Gigabit Ethernet Controller
**Driver: **r8169

Description: For unknown reason my OpenSuse 11.4 Tumbleweed Samba server occasionally loses Ethernet connectivity. It acts as though there was a bad cable, but I swapped cables and even a switch with no resulting change.

Symptoms: TX Packets are transmitted while the RX packet count remains at 0. I can ping loopback and the NIC IP address, but nothing beyond can be reached.

This has been an occasional problem that I have unsatisfactorily resolved in the past by switching from YaST2 ifup to NetworkManager and/or back. Up until now each utility swap resulted in restored network connectivity. Most recently, however, this procedure did not work and connectivity could not be restored. I spent most of one day researching the forums and trying every suggestion without success.

Solution: Finally, I decided to run OpenSuse 13.2 Live DVD to check hardware; upon loading I immediately obtained connectivity to the network and all worked as it should. That confirmed the problem was not related to hardware. I then booted back to Opensuse 11.4 installed on the hard drive. Checking ifconfig, I found that both the RX and TX packet count were incrementing. I was able to ping other hosts, Samba was connecting to Windows workstations, and the server was online and fully functional.

The cause: I can’t say. But after booting to 13.2 Live, apparently something was reset, flushed, or otherwise fixed. Bottom line, if you experience this issue - as many have - try a booting Live version of your OS. I hope it will help you as it did me.

Sorry, but this is confusing. When you have openSUSE 11.4, you are running a very,very old version. When you have Tumbleweed, you have something different. “OpenSUSE 11.4 Tumbleweed” is something that does not exist, or ever has existed (not only because of the spelling errors).

Using openSUSE 13.2 for anything else then historical interest is also not something to be encouraged.

Supported versions at the moment are openSUSE Tumbleweed and openSUSE Leap 42.3.