Lost boot menu after w10 update, no opensuse folder in /boot/EFI/

OK, again I’m having dual boot problems.

After a windows update yesterday this box is booting directly to windows 10. No problem, I thought, I’ll just boot opensuse from the UEFI BIOS boot override and refresh the bootloader in Yast.

But there’s no entry for opensuse, and the only option that works is windows.

Windows is in /sda, opensuse in /sdb/, both GPT formatted.

Originally, after some trouble some years ago after loosing the boot partition, I created a second 500 MB boot partition in /sdb in addition to the 100 MB boot partition created by windows in /sda and copied the EFI folder to it.

After that I could always see both entries in UEFI boot override, and both would start grub2 boot menu normally, even listing both windows entries, identifying which one was for sda and the other for sdb. And windows would boot normally from either one, as I expected.

I have this setup in a second box that is working normally, but I didn’t update windows 10 yet. Note that both windows versions are 2004, only the first one had yesterday’s update.

Since I couldn’t find a way to boot opensuse, I tried copying the /boot/EFI/opensuse/ folder on the second box to both boot partitions, not really expecting it to work as I believe there should be some kind of registration on the UEFI firmware, or something like that. From older posts here in the forum it seems that this can be done with efibootmgr, but I don’t know how to do this from outside the installed opensuse (nor from inside it very well, TBH).

This had two effects: the opensuse-secureboot (P1:Sansung SSD etc…), which is /sdb, appears in the overrides, and/but there is no entry for /sda, contrary to the box that is booting OK.

Things improved a bit, as booting from this entry drops me in a grub prompt, but I don’t know if I can use it to fix the issue.

As a side issue, in the override list there also appear an entry for drive /sdc, which is purely a data drive, with two partitions, one NTFS for windows/D and one EXT4 for backup of work files. This disk is older, and formatted as MBR - but the setup has worked fine the last three years more or less.

I understand I could copy the shim.efi file to the parent folder, but I’m wary of messing up the setup, as the /boot/EFI/opensuse files where not generated for this installation.

So, how can I install the correct EFI files? Can I use the installation DVD/USB rescue mode to do this?

Thank a lot,


Yes, you can. But before you try that, try selecting “Boot from hard drive” from the installation DVD/USB. There’s a chance that will get you into your system, and then you need only run Yast bootloader to reinstall booting.

If you need to use the rescue disk, then

efibootmgr -c -d "disk" -p "partition" -l '\EFI\opensuse\shim.efi' -L opensuse-secureboot

Here “disk” should be “/dev/sda” or “/dev/sdb” – whichever disk contains the EFI partition that you are using. And “partition” should be the partition number of the EFI partition that is normally mounted at “/boot/efi”.

I am getting old…

I’ve always booted in secure mode, and I got used to always select the opensuse-secureboot UEFI override, assuming the others wouldn’t work.

Not so. besides
opensuse-secureboot (P1:Sansung SSD etc…),

there is also
opensuse (P1:Sansung SSD etc…)

boot option, and selecting this actually worked, booting the installed openSUSE. Then it was just a matter of rewriting the bootloader from Yast, and now everything is OK.

And the opensuse-secureboot (P1:Sansung SSD etc…) in overrides also works…

So, I looked at secureboot and it is disabled.

Thank you nickert, for your help. It will certainly be usefull in the future.

OK, so I disabled CSM and enabled secure boot in UEFI BIOS.

It boot OK, with a text dialog on first boot asking to OK the key use and, on further boots, only briefly showing a text about EFI stub at the start.

I’ll probably keep messing with it until it breaks again. :stuck_out_tongue: