Lost all gnome mime type recognition after update

System stats: Dell D620 laptop running OpenSuse 11.0 64-bit, Gnome desktop (Gnome 2.22).

After a recent (in the past week) upgrade of packages, I seem to have lost all the mime type recognition in Gnome. I first noticed that I was no longer seeing thumbnails in my picture folders when viewing with nautilus. I also observed that newly created PDF files no longer had a mini thumbnail preview for an icon, just a generic text file icon. If I now try to drop an icon out of the application menu to the desktop to create a shortcut, it immediately turns into a generic text icon with the lable [application name].desktop. (existing desktop shortcuts have also changed)

ANY file that I right-click on and choose properties reports as type “plain text document”. if I open a termnal and use gvfs-info on ANY file it shows “standard::content-type: text/plain” and “standard::fast-content-type: application/octet-stream” this holds true for PDF, JPG, AVI, and any type of file I try it on. I thought it might be something in my user settings, so I cleared any ~/.local mime settings, but that didn’t work.

If I su to root in a terminal, or for that matter even log into GDM as root I get the same results. I also tried it as another user and it is the same, so this is a system-wide issue.

Recent package updates include some KDE4 packages (I need them for some apps I like to run in Gnome, like Okular, Amarok, and other KDE apps), Amarok, and Cairo-Dock2. I checked the version of the shared-mime-info package that I have and it reports version 0.60-2.1. With my very limited knowledge of how Gnome works with mime, I took a peek at some of the xml files in /usr/share/mime and there appers to be plenty of package and model files that LOOK okay.

Any ideas? I will provide any feedback asked for from someone kind enough to help.

Thanks in advance.

Hi my friend,
I had the same problem and solved it by copying the following directories to ~/.local/share/




Hope this help. Best, reef.

Thanks very much for the suggestion.

I tried it and it didn’t work though. :frowning:

I’ll keep searching and trying things.

Anyone else have any ideas or experienced this also?

The system fatally changed launchers on my desktop. - openSUSE Forums they supposedly fixed it there, not sure whether that is a typo though .cocal being .local.

Thanks for posting the link. I had found that thread before posting mine and had already tried that (it didn’t work). Unlike the poster of that thread my problem is affecting ALL users (even root!), so it appears to be a deeper problem than a user configuration file. I am stumped, but still trying.

In addition to upgrades and adding Cairo Dock 2, I downloaded an icon set from gnome-look.org and installed it as a theme. Is it possible that caused my mime database to go wonky?

If it affecting all users then, I would look into the refreshing the database The MIME Database

Strange you’ve got it for all accounts, as for the how I’m only picking up snippets reading through the mime section, so far from all knowing.

But no I don’t think it is related to the theme, but you would need to check do your files show the correct mime type. It is possible that the theme doesn’t have an icon for the mime though.

Mmm I’ve just checked now it’s KDE, but this I wouldn’t of thought makes the difference 0.60-2.1 <= where did you get this from? I can only see 0.51-12.14 on OSS

Thanks for the help and posting so quickly.

The 0.60-2.1 shared-mime-info package seems to come from KDE4:KDE:Factory:Desktop. I agree that the documentation for how Gnome organizes its mime database structure is confusing. I have been trying to wade through it myself.

I think I got it though!

I kept trying to use the “update-mime-database” command pointing to /usr/share/mime with no success. I then typed ECHO $XDG_DATA_DIRS to see what directories were configured for mime and it returned: “/etc/alacarte_system:/usr/local/share:/usr/share:/etc/opt/kde3/share:/opt/gnome/share:/opt/kde3/share”

I am not sure what the alacarte_system is, but the mime cache file there was empty, so I turned my attention to /opt gnome/share. I tried “update-mime-database /opt/gnome/share/mime” and that did the trick! I wonder if the mime database files at the default location (/usr/share/mime) got corrupted or overwritten somehow? It appears that refreshing the database from /opt/gnome/share/mime puts it back to gnome defaults (which in my case makes it work again!)

Thanks for help and suggestions.