Lost ability to configure Desktop both dispays after recent update


After a recent Tumbleweed update of 250+ files I have lost the ability to configure the Desktop settings on both displays. (Dual display set-up obviously.)

For example, I could previously set the Desktop wallpaper background on both displays. Now I can only do that on 1 display. The other display gets an un-changable black background and no response to right-mouse-click which should present a menu to change the display settings.

Try using the KDE Display and Monitor app to check/change the resolution of your display(s). If it is showing as correct, apply a different setting and then apply the correct setting. For me this survives until the next boot.

Same behaviour here. Works but does not survive reboot.

Could be a QT bug


Same problem here :frowning:
The QT bug link is here: https://bugreports.qt.io/browse/QTBUG-86604
As suggested on that bug, running

plasmashell --replace
fixes the problem (for me) until next reboot.


Just came back to openSUSE after being elsewhere for a long time.

Looking to see if there is an update with this issue.

I have a laptop connected to a second monitor. I am trying to set it up so it only uses the second monitor and not the laptop screen as they are not side-by-side.

The primary desktop only shows my desktop icons, while the non-primary desktop shows the main panel. It didn’t matter which one I set as primary, it was missing the panel.

Duplicating makes both of them act as primary desktops (no panel) and the different screen size / resolution also effects it.

I am able to get the external monitor usable so long as I have them of them running, overlaping each other and running as mentioned

plasmashell --replace

Since you mentioned that it doesn’t stick between reboots I set up a script and added that to autorun when I log in.

Set it by using System settings > Startup and Shutdown > Autostart > Add Login script > [add an executable file w/code below]]

plasmashell --replace &

Do you have any updates or tricks that may work?

Try the following: Go into background services in systemsettings5, deselect “Kscreen 2” and apply. Log out of Plasma and delete ~/.local/share/kscreen2/* and ~/.cache/* while Plasma is not running. From then you can use a startup xrandr script that should stick. Mine are in /etc/X11/xinit/xinitrc.d/. Arandr can be used to create such a script.