Losing mouse control after period of inactivity, 12.3 KDE 64-bit

My system is a desktop tower with a fairly recent Intel motherboard with built-in Intel graphics. It does not have any custom Xorg configuration files - I installed 12.2 fresh on it in November and everything worked right out of the box. I upgraded to 12.3 yesterday, and now have a situation where the mouse will stop working (the cursor is frozen in its last location, and the buttons are unresponsive) after a period of inactivity, which seems to be about 30 minutes. It will not return if I hit the double ctrl-alt-bksp key sequence to restart KDE and login again. The only solution at this point is ctrl-alt-del and use the keyboard to select restarting the system.

This is not related to power management or the screen saved, as I turned off both features just to make sure. It only seems to happen if there are no open applications on the current KDE pane - that is it has not happened if I have Firefox open on a webpage with an animated icon. My mouse is a plain USB model, I think Microsoft optical.

I have some desktop effects enabled and did not try disabling that yet.

CORRECTION. The loss of mouse control happens regardless of what is running on the current KDE pane. Disregard my comment about Firefox - it happens consistently after the period of inactivity.

Should I report this as a bug?

On 03/30/2013 04:16 AM, gnumattx wrote:
> Should I report this as a bug?

none of this may help, but:

if you use YaST > Security and Users > User and Group Management >
Add to creat a new test-user, then log out and log back into that
test-user and do a little looking around and then let it all be idle
for 45 minutes or an hour, then is the mouse still working ok…if
so, let us know…if not:

this mouse, does it have a brand name and model number on the bottom

how old is it?

is it wireless? or wired directly to a USB port on the computer?

or, is it wired through a hub? if wired through a hub is that hub

if you plug that mouse into any other USB port on the machine, does
the problem go away? (if you have ports on the front and back: move
it from front to back, or back to front–if on a hub, move it to the

do you have a different mouse you can use, to see if it gives the
same problem?

if you open the BIOS, are there any “energy management” or “energy
savings features” which can be set? are any set to 30 minutes? is the
mouse mentioned anywhere?

you turned off all power management, but please go to Personal
Settings - Configure Desktop > Hardware > Power Management > Global
Settings (on the left) and set the Profile Assignment (on the right)
to “Performance” for When AC power is plugged in (or something like
that)…and then click on “Power Profiles” (left side), then
select/highlight the “Performance” profile and then on the right is
there anything set to 30 minutes? if so, set to 15 or 45 minutes and
see if your mouse begins to freeze at whatever you set that value to…

then, go to Personal Settings - Configure Desktop > Hardware > Input
Devices > Mouse and check on each tab (General, Advanced, Mouse
Navigation) just to make sure there is nothing hidden there about
sleeping mice, or energy saving mouse, or . . .



Hi, thanks, I was thinking along the same lines as you, so I am trying alternate BIOS settings, alternate user, alternate mouse, plus turning off desktop effects. I will reply with a status once I have completed these tests. Indeed the mouse is old, and it is a USB mouse - no hub involved, moving the USB port had no effect.

I came across a second problem when trying the Lock function (I figured locking the desktop rather than leave it idle might be a work-around). I am able to lock the computer without issue, but when I give the password to unlock, it unlocks but gives a black screen with no desktop - the mouse cursor moves but you can’t do anything until hitting double ctrl-alt-bksp and logging in again. There was no period of inactivity with this test, I locked and immediately unlocked. Note that this would be a show-stopper for upgrading to 12.3 in the Lab where we are required to lock screens when not in use.

Finally, in case anyone hasn’t spread the word yet, it is now necessary to in Personal Settings -> Input Devices “Numlock on KDE start-up” must be set to “Turn on”. At least for users doing a 12.2 -> 12.3 upgrade. I understand other users have discovered this as well.

We’ll be in touch. Have a good one.

On 03/30/2013 01:56 PM, gnumattx wrote:
> Note that this would
> be a show-stopper for upgrading to 12.3 in the Lab where we are required
> to lock screens when not in use.

do you have more than one computer with this same mouse, and more
than one is showing this same “sleeping mouse” problem???

if so, then hmmmmmmmm…maybe it is some kind of systemd
problem…OR not…


I will have an accurate answer within 24 hours, I still need to run a few more tests with different USB connections / different mice. But I know what has been happening: USB ports are dropping power after a period of time in spite of all possible power options being set not to do that. The optical mouse stopped working when no more power is supplied through USB. It would be quite a coincidence that this began when I did the 12.3 upgrade, but possible, I certainly hope its hardware - maybe one of my USB devices is going downhill and messing things up for everyone else connected. Yes we have other hosts in the Lab but mine is the only one running 12.3 for now - it was designated as the upgrade test host. Hopefully I’ll have more on the screen lock issue tomorrow also.

On 04/01/2013 07:26 PM, gnumattx wrote:
> the only one running 12.3 for now

just for fun, you might boot up a 12.3 Live CD (of whichever DE you
like) and see if you mouse sleeps then…if it does it is either an
incompatibility with 12.3 or a hardware problem…

but, if you then booted from 12.2 Live CD and the mouse sleeps i
think you know for sure it is a hardware problem…right, because you
didn’t have this on 12.2, right?

oh, if you confirm it is not hardware, but something 12.3 then i’m
gonna hand you off to some smarter folks than me . . .


OK, well embarrassment here… totally. It was some kind of developing hardware problem among my USB devices. I replaced the mouse plus another cable that had a bit of a crimp in it, and the problem has disappeared. It was such an odd coincidence that it showed up when I did the 12.3 upgrade! Also the screen lock is working fine now.

By the way, yes the live CDs are great debugging tools. I’d already tried that fairly early on. I would have tried the Gnome live CD had the problem still existed to see if it was something in KDE.

So 12.3 is cleared for deployment in our Lab, and everyone here is consistently pleased with the OpenSUSE approach to GNU / Linux. We know our distros pretty well, and haven’t thought of using anything else in eight years. Thanks.

On 04/03/2013 08:16 PM, gnumattx wrote:
> well embarrassment here…

don’t be!
happy you got it sorted out…