Losing Internet Connecrtion quickly

Hello, I keep losing my Internet Connection(DSL) very quickly. Usually after a couple of minutes, it’s absolutely unpredictable. And then, it gets difficult to reconnect. And if I succeed in reconnecting, I again lose the connection quite quickly.

Here are some logs from the ifcfg-dsl0.log:

SuSE Meta pppd (smpppd-ifcfg), Version 1.60.46 on linux-6clg.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin rp-pppoe.so loaded.
pppd[0]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: PPP session is 6890
pppd[0]: Connected to 00:04:0e:6d:99:0d via interface eth0
pppd[0]: Renamed interface ppp0 to dsl0
pppd[0]: Using interface dsl0
Status is: connecting
pppd[0]: Connect: dsl0 <–> eth0
pppd[0]: PAP authentication succeeded
pppd[0]: peer from calling number 00:04:0E:6D:99:0D authorized
pppd[0]: replacing old default route to eth0 []
pppd[0]: local IP address XXX.XXX.XXX.XXX
pppd[0]: remote IP address YYY.YYY.YYY.YYY
pppd[0]: primary DNS address
pppd[0]: secondary DNS address
pppd[0]: Script /etc/ppp/ip-up finished (pid 4720), status = 0x0
Status is: connected
pppd[0]: No response to 4 echo-requests
pppd[0]: Serial link appears to be disconnected.
pppd[0]: Connect time 9.0 minutes.
pppd[0]: Sent 151203 bytes, received 555603 bytes.
pppd[0]: restoring old default route to eth0 []
pppd[0]: Script /etc/ppp/ip-down finished (pid 7197), status = 0x0
Status is: disconnected
pppd[0]: Connection terminated.
pppd[0]: Modem hangup
pppd[0] died: A modem hung up the phone (exit code 16)

I don’t have this problem with my old computer(I guess, Suse 10.3?). And I have this problem with two different modems.

Please help!

Sorry, “Losing Internet Connection quickly”.

I don’t know how to change this, if somebody wants to change this, no problem.

Did you already set the option for the connection NOT to auto-hang-up for inactivity?

Maybe try and put in /etc/ppp/options

lcp-echo-interval 0
lcp-echo-failure 0

so you do not get disconnected due to a no response to the ECHO request.


Thanks a lot ghostintheruins!

Actually, I still had problems afterward. As my computer constantly messed up with the DNS-Servers. Strangely, it seems it all got better after I had played with the “Udev”-Rules.

But your answers helped me a lot!

I will do some further tests in the coming days. And I hope everything will be alright!

Glad I could help. :slight_smile:

Regarding the dns servers I guess you could use manually set ones (e.g. google’s or opendns) and set your connection NOT to update / change them (I mean /etc/resolv.conf), this unless you need to use your ISP’s DNS servers.

You can use also your ISP ones if you know them and if you are sure you do not need to let them change automatically.

Check: https://code.google.com/speed/public-dns/ and http;//www.opendns.com/


I’m sorry, it didn’t disconnect anymore. On the other side, I couldn’t transfer data from or to the Internet.

I guess the problem is linked to the drivers:

Wired internet - keep loosing connection