loses usb

Installed about a week ago, everything works great but this: Periodically I stop detecting usb drives. Sometimes rebooting brings back the functionality, and if not, reinstalling the kernel does. Logging out and back in didin’t work the couple of times I’ve tried. Also I have a Soundbyte (usb speaker that’s louder than my laptop otherwise) affected similarly, but a usb mouse continues to work just fine. It’s not the worse problem I’ve ever seen, but a puzzle. Any ideas what might be cause periodic bouts of usb blindness?

Possibly they are USB 2.0 ports, seems another user reported an issue like this, adding the iommu=soft to the bootloader kernel command line options fixed it…
Ref: http://forums.opensuse.org/showthread.php?t=530911

Clarification - by “not detected” I mean that the KDE device notifier doesn’t see them, or for the usb speaker that it’s greyed out (not selecteable) in the KDE Setting multimedia module, just as when it’s not plugged in. Some of these usb sticks are bootable and detected at boot. Happens with both FAT32 and ext3 formats - that is, where the same usb stick is detected this time but not next time - but the critters always show up for gnome-multi-writer. However, it doesn’t seem to be looking for partitions or files, only for devices to write to.

After initial post here, I reinstalled the kernel (and usb libraries) and rebooted, but this time that didn’t clear the problem. -GEF

EDIT: Malcom, thanks, didn’t see your reply before I posted my clarification. My system’s busy with a download at the moment, but I’ll try that boot option as soon as it’s done and report back.

bootloader option made no difference for me. Like the other fellow, I have both USB 2 & 3 ports, but it seems to make no difference which I use. However I have a one USB stick that I can detect, 3 other that I can’t. While that’s a lousy sample size, the detectable one I installed as live image and left alone since. The others I’ve been using for either sneakernet or trying different versions of linux (migrating to my new laptop and setting up the old for a new home). All this activity’s only in the last week, though, so in total I shouldn’t have worn anything out.

Is this a desktop system, not a power supply issue with the 5V rail?

Nope, laptop. I need more data to isolate, i.e., more usb devices in combination with another computer, which I don’t have available tonight. -GEF

Well, I think this has to go down as solved. Order of events: 1) Had actual problem temporarily resolved by re-installing kernel and finally resolved by a kernel upgrade. 2) soon thereafter had other problems including bad usb stick and user error mistaken for recurrence of the original problem. -GEF

Thanks for that update.