Loosing windows entry in grub after yast upgrade

When I run yast system update, I often loose my windows entry in grub menu.
I have to go to yast -> configuring the boot loader -> bootlader options
Then I uncheck/check “probe foreign os” (not sure if this step is necessary), and apply.
At next reboot I have the windows entry again.
How to avoid this after yast updates ?


Now I can say I don’t need to uncheck.check the box “probe foreign os”.
So when yast update the system it does not check foreign os, and I need to force recheck with “bootlader options” menu
How to fix this ?