Looking for HOWTO to setup a camcorder via firewire card

Hi. I bought a firewire card after I install 11.1. Then I use yast to install libraries that can be related (I installed dvgrab, libraw1394, libavc1394, etc). The card can be recognized at boot time.

Welcome to openSUSE 11.1 - Kernel (0).

jesse@rainbowv:~> dmesg | grep 1394
ohci1394 0000:04:09.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> IRQ 18
ohci1394: fw-host0: Get PHY Reg timeout [0x00000000/0x00000000/100]
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[18] MMIO=[fdbff000-fdbff7ff] Max
Packet=[2048] IR/IT contexts=[8/8]
ohci1394: fw-host0: Get PHY Reg timeout [0x00000000/0x00000000/100]
ohci1394: fw-host0: Get PHY Reg timeout [0x00000000/0x00000000/100]

I then connect my camcorder. Nothing seems to happen. I run dvgrab and it said it can’t find any camera.

Is there any HOWTO somewhere to tell me what else I need to configure ?


Jesse Lee

My camcorder is USB based and it “just works” for dragging and dropping video files from the camcorder to my PC’s hard drive.

There is a video wiki here which makes reference to 1394/firewire, but its not well written (saying it politely): Video editing - openSUSE

There is a custom application one can compile and build for listing connected firewire devices. I posted on it here: Firewire equivalent of lsusb lspci ? - openSUSE Forums

My external hard drive firewire devices “just work” with openSUSE-11.1. I plug them in and I get a popup. … Sorry that I can’t offer more help re: your firewire camcorder … maybe someone who has such a device working with openSUSE-11.1 can offer up their experience.

I have a camcorder connected via firewire also. I am not expert on this. I just use it to play with some of my family event’s video. There is nothing special to configure here it just work. I use kino and kdenlive to access my camcorder.

dvgrab from packman repo might be useful.

Thanks for the tips. I will give them a try.

If you will try the kdenlive from the packman repo use the ffmpeg svn version this is the one that works on my kdenlive installation. There are two versions of it and you can choose it using the version section in yast2 sofware management.

I still can’t it to work with openSuSE 11.1. So I install openSuSE 11.2 from scratch this time. Still it doesn’t work. I searched the web for answers and tried what I can find. I loaded raw1394, dv1394 and video1394 and here is my udev rules (as copied from vlc web site)

KERNEL==“raw1394”, MODE=“0666”, NAME="%k"
KERNEL==“dv1394”, MODE=“0666”, NAME=“dv1394/%k”
KERNEL==“video1394*”, MODE=“0666”, NAME=“video1394/%n”

Here is the info of my firewire card.

lspci | grep 1394
04:07.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 61)

Running dvgrab returns “Error: No camera exists”

you are going to have to search for yourself; the experience of others is firewire works; so no-one else has had to search all this; our first install with firewire was Suse 9.3 and we are still using a 9.3partition as we still use MainActor;

so sorry; you need to be sure of your hardware; is there a local LUG (linux users group) near you: sounds very hardware-related; you need to try gear out with others

To be certain of the hardware, I toke it out and install it on a Windows XP machine. It works perfectly and I can capture the DV video without any problem.

I tried out another firewire card (bought from Pinnacle Studio 8 a long time ago) taken out from the XP machine and plug it into the openSuSE 11.2 machine. As soon as I turn on the DV camcorder, the system log is filled with “SelfID received but NodeID invalid” messages until I turn off the camcorder.

Searched the web for this particular message but none of them is really useful.

It is really frustrated that linux (not just openSuSE) doesn’t really say what exactly the problem is.

I searched the web that there is new firewire stack out there. Guess I have to wait until the next openSuSE with the new firewire stack.

thank you for clarifying the hardware; sorry to hear you are stuck like this; sometimes I feel you have to get an application working, rather than be “loyal” to a distro; what about trying … say … a fedora 12 and see if you have any joy?

You could also write a bug report on openSUSE on this. This will increase the probability that it is fixed in a subsequent openSUSE release, and may even result in a fix to the current openSUSE release. There is guidance for writing such a bug report here:
Submitting Bug Reports - openSUSE
… please note the bug will likely only be fixed if you support the developers (who reply to the bug report) providing them information that they may request from time to time. After you provide them the information, you need to reset the flag in the bug report from “need info” to “new”.