Looking for alternatives to sax2 for Intel graphics ?

I’m wondering if there are any alternatives to sax2 (ie some “wizard” script) for creating a custom xorg.conf file for openSUSE-11.2 ? (or 11.1 ? ) . If so, it could be useful for me tonight.

Background:

A friend is dropping by tonight with their Fujitsu-Siemens Amilo L6820 laptop w/1.2GB RAM and Intel 82845 graphics. On the weekend I tried and failed to get the 11.1/11.2 liveCDs GUI to work (10.3 does work) although I could boot to run level 3. I documented my efforts here: Failed efforts with openSUSE-11.1 and 11.2 on Amilo L6820 laptop There is also a bug report here: https://bugzilla.novell.com/show_bug.cgi?id=556413

One of the problem symptoms is sax2 freezes most the time when trying to create an xorg.conf. I won’t install 11.1/11.2 on this laptop if the liveCDs don’t work as this laptop is “mission critical” for my friend.

Planned puppy Linux approach.

Then I read of a user succeeding with 11.2 with an 82845 (who had same symptoms) by using an xorg.conf from PuppyLinux 4.3 .

Then I read a post by user opsmgr Bitten by bug in Suse 11.2 X11 & Intel 845 Graphics - Solved - openSUSE Forums who noted they encountered a similar problem with an 82845 graphics on openSUSE-11.2 and implemented a work around using a Puppy Linux xorg.conf file. I’ve read of a couple of other cases where users did the same (with Ubuntu).

So I downloaded Puppy Linux 4.3.1 last night and played with it (as a liveCD, its very nice by the way, and very light weight and fast). The Puppy IRC channel is also very friendly for support (unlike Fedora’s). My plan tonight is to boot to Puppy Linux liveCD, use their tool to create an xorg.conf, and then copy that to a USB stick, reboot to openSUSE-11.2 (or 11.1) run level 3 and copy the Puppy xorg.conf to /etc/X11 directory and then try to boot as a test. If that test works, I will install 11.1/11.2.

Note this PC is “mission critical” for my friend and his wife (ie their only PC).

On my nVidia hardware I examined the Puppy-Linux xorg.conf and its VERY simple, which causes me concern that it may not work for 11.2 (even though I’ve read it worked for a few users).

Alternate Ubuntu users xorg.

I note the same problem exists on Ubuntu with this 82845 graphics. But I also dug up a simple xorg.conf file of a user (Ubuntu) who claimed it worked with their 82845 graphics (with vesa driver) My tryst with Linux: Running Ubuntu Karmic on Intel 82845G/GL[Brookdale-G]/GE Chipset

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor  "Configured Monitor"
 Device  "Configured Video Device"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver  "vesa"
EndSection

However the above looks “too simple” and I’m skeptical.

Other Options ??

So I am curious, if Puppy Linux xorg.conf does not work, **what are my options for creating an xorg.conf, since Sax2 freezes ? **

I don’t have time to hand edit and explore via trial and error the xorg.conf. Its 90 minutes tonight or never. And I hate failing. :slight_smile: … So its either succeed tonight, or possibly never with this laptop.

I note there is the possibility of:

Xorg -configure

if run as root.

I have not run this since my Red Hat days (1998-2001) and I recall I failed then. :frowning: (back then I ended up using someone else’s xfree86.conf from similar hardware and hand editing it).

it is no point in making xorg.conf
every time X starts with new configuration and sax2 has to release the X for desktop use.
i have tried many xorg.conf with no result.
sax2 uses /tmp and makes a xorg,conf for the session and approves it for user.
getting a new video card only seems reliable solution.
i am also stuck with 845 mother board p4 cpu.
i could not remove sax2 and get the X to start.

I agree sax2 does not handle this. Support of sax2 has stopped as it is being depreciated and something in the Intel drivers and/or Kernel since openSUSE-10.3 has changed such that sax2 no longer functions with the 82845 graphics. But I do note Fedora-12 liveCD will run with this graphics (with no xorg.conf file) and I have read of users who did boot with a Puppy Linux live CD on an 82845 graphics, take the xorg.conf and use it successfully on openSUSE-11.2 (in one case) and on Ubuntu (in another case). Hence assuming those users are accurate in what they claim, that suggests that there might be a possibility that a different xorg.conf file will work.

If another xorg.conf file does not work for any 82845, how does one explain the success of those two users whose PC has an 82845?

I figure all one can do is try - but indeed you could be correct, … it may not work.

This is a 5 year old laptop, so unfortunately a new video card is not a viable solution in this case.

I’ll let you know the results if we succeed tonight. … but I see no need to remove the tool sax2,… it just creates the config file (xorg.conf) possibly in more than one place.

If the liveCD will boot (with a custom xorg.conf) then I plan to install 11.2 in a text install, and then afterward configure the graphics.

Further to this, what openSUSE version are you basing your experience on ?

I note this in the openSUSE-11.2 release notes: openSUSE 11.2 Release Notes

YaST and X.Org Configuration (Keyboard, Mouse, Graphics Board, and Monitor)

In the past, YaST offered an configuration interface for the graphical desktop (X.org) such as keyboard, mouse, graphics board, and monitor. During the installation a suitable xorg.conf was created.

In most cases it is no longer needed because the Xserver is now able to automatically configure the system. If it fails for your system, try the following steps:

  1.  Check whether an old /etc/X11/xorg.conf file exists. If so, move it away and start your desktop again.
    
  2.  If it still does not work, run sax2 from the command line and execute the configuration procedure.
    
  3.  To adjust hardware components to your personal needs, start the GNOME desktop control center or Configure Desktop in KDE, and configure your devices such as the mouse or keyboard. The display configuration dialogs also let you configure multiple monitor setups. To configure multiple monitors, in other desktop environments, use xrandr.
    

For more information, see the Desktop User Guides shipping with openSUSE. They are also available from Documentation - openSUSE

Plus I note this Linux Magazine URL: OpenSUSE Says Farewell to SaX2 - Linux Magazine Online

That suggests to me that sax2 is not run by default and does not dynamically effect files upon boot, which I think is your view? My apologies if I do not understand what you are trying to say.

Success !!

Earlier this evening, we successfully installed 11.2 on this Fujitsu-Siemens Amilo L6820 laptop with the Intel 82845 graphics hardware. All is not rosy, but it IS up and running.

First, prior to installing, we booted to Puppy Linux and obtained the xorg.conf from Puppy Linux. It took some trial and error effort to get Puppy Linux to boot to 1024x768 (initially it was only black screen, and later 800x600) but eventually we succeeded.

We then booted to the openSUSE-11.2 liveCD in run level 3, copied the puppy linux xorg.conf file over, tried startx, and failure. :frowning: We had a black background, on which we could start X-Windows apps, but no plasma, no kicker, no tool bar, only black. Apps had to be started via <alt><f2> and konsole. So clearly the puppy xorg.conf was not good enough as copied. We did note there were additional puppy linux files reference by the puppy xorg.conf, that we still could copy over to the hard drive and try, which we did not do.

BUT before trying that, we then used the simple xorg.conf I saw on a Ubuntu site (quoted above) with the openSUSE-11.2 liveCD:

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor  "Configured Monitor"
 Device  "Configured Video Device"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver  "vesa"
EndSection

I tried that xorg.conf in the openSUSE-11.2 liveCD and X window booted to an 800x600 display, filling part of the screen (but not all). This was actually preferable to what I experienced on Fedora-12.

This gave us confidence to go ahead and install 11.2.

So we installed openSUSE-11.2 from the DVD (selecting KDE4 as desktop) using a text mode install, and as anticipated, after the install was complete, when the first boot took place, as expected we had only black screen with no desktop. We did hear the startup sound.

So we restarted with <CTRL><ALT><Delete> a couple of times ( <CTRL><ALT><Backspace> would not kill the desktop) and this time pressed 3 to boot to run level 3. We logged in, switched to root, but instead of using the above xorg.conf, we saw an xorg.conf.install file. So figuring nothing ventured, nothing gained, we copied the xorg.conf.install to xorg.conf, and typed “startx”.

Much to my surprise, X window booted to KDE4 with this xorg.conf.install file as the xorg.conf. The screen was only 800x600, but it was a start. Enough for now, and maybe in late Feb or early March, when I have access to this laptop again, I’ll be able to fix the xorg.conf to get a better resolution.

I noted the KDE4 had NO plasma Desktop Folder (if I have the term correct) possibly because this is only an 800x600 resolution. But thats not critical. I think I can fix that later.

I’m also struggling with a head-cold and mild fever, so it was nice to partially succeed despite those negative factors (albeit more work left to do).