Looking for a specific widget for my KDE netbook.

Hello all. I am a linux newbie. I started using openSuse when 11.4 was released and before that I was using Kubuntu since august or september.

When I had kubuntu 10.10 on my netbook, I was using that option that made my gui optimized for netbooks and that’s what im currently using with my opensuse. Kubuntu had a widget, though, that would sit on the horisontal panel on the top of the screen, and it would represent the menu bar of the program that had focus. The menu bar of the program actually became a drop down menu on my panel. I dont have the live image of kubuntu any more and its quite a hassle for me to redownload it and I couldnt find anything specific about that widget on the internet.

Could someone tell me where can I find it or at least how can I search for it in an effective way?

Thank-you in advance

me thinks it is called the plasma-widget-menubar (A Plasma widget to display menubar of application windows), as best as recall it requires QT 4.8 (or a patched QT 4.7) see [opensuse-kde] plasma-widget-menubar and patched Qt for openSUSE?](http://lists.suse.com/opensuse-kde/2010-12/msg00028.html). Also, I think it’s suppsed to eventually get into KDE but in the mean time maybe only available in Kubuntu

update: having said the above there appears to be a version for 11.3 in the build service https://build.opensuse.org/package/show?package=kde4-plasma-widget-menubar&project=home%3Amalcolmlewis%3AMiscellanous

so I dl’ed the src.rpm and rebuilt and installed it with no errors. But it did not work (at least for me), it appeared in the widget bar and the icon looked fine but it did nothing when installed

wow thank you a lot. I didnt know a widget can be OS-specific. I thought that all kde widgets were globally able to be run by the same version of kde or something…

not all distro’s are identical and maybe Kubuntu patched their version of QT so that the widget could work (I doubt they use QT 4.8 but don’t know).

there’s a thread on the KDE forum about this worth reading KDE4 and the MacOS-menubar • KDE Community Forums

I know that this thread is a couple of years old, but I find myself in a similar situation as the original poster. The thing is, ths functionality is supposedly already in kde 4.10 (which I am running on openSuse 12.3). However, I also cannot get the widget to actually work. I knew enough to install appmenu-qt, but no go.

I am originally a Kubuntu user as well. The odd thing is that I tried Fedora KDE prior to openSuse (kde). The widget worked fine in Fedora. I find this odd as these two distros seem very similar to me (perhaps not as much as it looks though, huh?).

Anyway, any thoughts on how to get this to work? It is nice because it saves another row of space on the netbook settings. I assume that there must be some additional library that is needed.

Anyway, thanks in advance for any help.

Hot Dog I figured it out. I had everything installed correctly, I simply had to adjust the system settings. So, for all those that have kde 4.10 + installed and are similarly puzzled as I was, do this:

In system settings, go to Application Appearance / Style (With oxygen) / Fine Tuning. Here, you will find different options for setting the menubar (this is also where you can have it be a button in the titlebar.)

Thank you very much for replying here.
I started searching for this again with the release of 12.3.
I’m still trying to get the menubar loaded on a widget and I’ve figured out this is done by selecting “Export only” in the fine tuning section, but I don’t know what widget I’m supposed to use and where to find it.

This is brilliant because I had the exact opposite problem. Thanks for the tip, it’s working beautifully now, at least for kde apps. You’ll want to go to software.opensuse.org: Download openSUSE 12.3 and search for plasma-widget-menubar. After you install it you can easily find it among the rest of your widgets.

oh and if you search for appmenu-gtk and add the necessary repository/packages (requires downgrading gtk if you are on tumbleweed at least) you can get the menubar working on gtk apps too!