Long start-up time for some applilcations

Hi there :slight_smile:
I am having trouble starting some applications in opensuse. For example when I type mc (midnight commander) in terminal and hit enter it takes MORE than 15 seconds for it to start. Ive got the same problem with firefox too >:(

System : Latest Version of OpenSuse 64 Bit.

Is it possible to have this issue resolved in opensuse?

Thanks.

I suspect this a problem specific to your computer. mc starts virtually immediately for me.

the issue is almost vertainly specific to your system. Without knowing anything about your system I can only guess that it is a lack of available resources to run those programs. While you are waiting for the applications to load is your hard drive thrashing? This probably indicates low on memory so is using swap memory.

Other than that you will need to tell us a lot more about your system (hardware, openSUSE version, DE etc).

So do you assume that this cannot be resoled?

I have modern laptop with 4Gb RAM and SSD :slight_smile: the hard drive diod isnt lighting. it looks like the pc isnt busy at all while trying to open those apps

here is the system info

Linux 3.17.1-52.g5c4d099-desktop
openSUSE 13.1 (Bottle) (x86_64)

On 2014-10-27 00:26, smartalgorithm wrote:
>
> here is the system info
>
> Linux 3.17.1-52.g5c4d099-desktop
> openSUSE 13.1 (Bottle) (x86_64)

Not enough. Way, way more. :slight_smile:

Try posting “free -h” here

Please run this command in a terminal:


free -h

and paste it all here, from initial command prompt, to last command prompt, in a single mouse sweep, and please do so inside code tags (the ‘#’ button in the forum editor).
http://susepaste.org/images/15093674.jpg

Same with:


lsblk --output NAME,KNAME,RM,SIZE,RO,TYPE,FSTYPE,LABEL,PARTLABEL,MOUNTPOINT,UUID,PARTUUID,WWN,MODEL,ALIGNMENT
hdparm -tT /dev/sda
smartctl -a /dev/sda
df -h

If your drive is not sda, change it.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

here is it


aram@linux-f9w1:~> free -h             total       used       free     shared    buffers     cached
Mem:          3.8G       849M       2.9G        57M       126M       363M
-/+ buffers/cache:       359M       3.4G
Swap:         2.0G         0B       2.0G



and this

aram@linux-f9w1:~> lsblk --output NAME,KNAME,RM,SIZE,RO,TYPE,FSTYPE,LABEL,PARTLABEL,MOUNTPOINT,UUID,PARTUUID,WWN,MODEL,ALIGNMENT
NAME   KNAME RM   SIZE RO TYPE FSTYPE LABEL PARTLABEL MOUNTPOINT UUID PARTUUID WWN MODEL            ALIGNMENT
sda    sda    0 111.8G  0 disk                                                     KINGSTON SH103S3         0
├─sda1 sda1   0     2G  0 part                        [SWAP]                                                0
└─sda2 sda2   0 109.8G  0 part                        /                                                     0
sr0    sr0    1  1024M  0 rom                                                      DVD+-RW GT60N            0



confusing?:slight_smile:

OS boots up on a SSD drive, so it takes 1-2 seconds… the problem isnt with hard drive for sure, this is specific for some apps only… >:(

look how long it takes…

[video]https://dl.dropboxusercontent.com/u/53352759/recordingmc.mp4[/video]

Hi,

I remember someone having such an issue with mc. Two minutes to start but he hadn’t a ssd… (If you understand French: https://www.alionet.org/showthread.php?29139).

He first disabled ipv6 and that solved his problem but he wasn’t satisfied with this solution. So he added:

search home

to his /etc/resolv.conf. That solved his problem too without disabling ipv6.

I don’t know if it’s related to your problem, but you can give a try.

open a separate konsole and run top open mc in the old konsole and whatch top see if anything is odd.

That is slow

On 2014-10-27 02:16, gogalthorp wrote:
>
> open a separate konsole and run top open mc in the old konsole and
> whatch top see if anything is odd.

And “iotop -o” on another terminal, as root. You will have to install it
first.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On 2014-10-27 01:26, smartalgorithm wrote:

>
> confusing?:slight_smile:

No, but you haven’t posted everything I asked for.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

smartalgorithm adjusted his tin foil beanie and wrote:

>
> here is the system info
>
> Linux 3.17.1-52.g5c4d099-desktop
> openSUSE 13.1 (Bottle) (x86_64)
>
>

Did you have this problem with the 3.16 kernel?


Mark
Caveat emptor
Nullus en verba
Nil Illigitimi Carborundum

It’ll save some questions and provide a better response if distribution version of OpenSUSE and desktop name/version are supplied. :slight_smile:
Also what has changed: new install, any software updates, new hardware, change internet provider, config changes…

From Console:

lsb_release -rd            # Distribution     
echo $DESKTOP_SESSION            # Which desktop
mate-about                       # MATE version
kde4-config -v                   # KDE version
rpm -qa --last | head -n5        # Last 5 updates

From GUI:
YaST2 -> Release Notes
Almost any desktop application (like configuration or file manager), select Help -> About

Without knowing more it could be:
network problem
hardware problem
system config
kde indexing

Firefox and MC are slow, which others?
Any messages in the system log that might indicate a failure?

If it isn’t hardware (like a bad sector), maybe networking (search MC and slow startup, lots of hits).

Hi all,
First of all i want to tank you all who tried to help me!!! Thank YOU!!!
And ive got this problem solved with latest updates in tumbleweed (those apps are starting faster than light !!!)… Dont know what was causing this issue, but i think that was related to some specific hardware combination maybe… i dont know. So everyone who have this issue you either can wait for an update ooor upgrade your system manually to the latest possible version…

Thanks and bye.