Long RAID sync silently prevents shutdown on new installation

I was having a strange problem whereby my new 15.4 Leap installation was refusing to shut down. I checked the shutdown logs and various forum suggestions here, none of which gave any clue or helped.

I later ran the Power Management setup and it reported that disk manager was blocking sleep screen locking mdraid-sync-job

And indeed checking this there was a very long RAID sync up going on between the two new drives.

Presumably this was blocking shutdown as well but I didn’t get any warnings on screen or anywhere in the logs while this was going on.

Once I’d allowed the sync to complete (several hours) then shutdown worked as normal.
I wasn’t expecting a long sync on two new drives, I don’t remember seeing this on previous RAID setups.

So anyway I get that preventing shutdown is correct behaviour but no notification of it anywhere completely threw me.

Should I open a bug for this?

1 Like

I would read Monitoring your system - Linux Raid Wiki first. I don’t think a bug report would be likely to produce fruit. Also I don’t think most RAID users are in the habit of frequent shutdowns that would make this a more important feature. Also it would probably depend on your DE, so probably the report would need to goto your DE upstream.

What exactly does it mean? Where you see it? What you did, what you observed?

Re: monotoring yes that’s how I worked out what was going on (eventually)

When shutting down it just went to a black screen and froze at that stage. Pressing ‘Esc’ to show the log also showed nothing. So a black screen with no indication of what was going on and no visible log either. It would happen to anyone who has just set up a new RAID array and tries to shut down.