In 11.4 I can no more logout without password for root, allthough in Personal settings> Systemsettings>Loginscreen>Shutdown all local users are allowed to shutdown.

See what the setting is in Yast - System - /etc/sysconf Editor - DeskTop - DISPLAYMANAGER_SHUTDOWN

Set to all if it is set wrong.

Do you mean “logout” or “shutdown”. You seem to mix up these.

Shutdown. It worked until update to 11.4. I didn’t change /etc/sysconf Editor - DeskTop - DISPLAYMANAGER_SHUTDOWN, the update did.
Thanks to gogalthorp, it works now.
So it must be an error: Setting it Personal settings>Systemsettings doesn’t work, in /etc/sysconf Editor it works.