Logout right after login.

This problem:

jone@linux:~> cat /home/jone/.xsession-errors-\:0

Invalid MIT-MAGIC-COOKIE-1 keyCan't open display :0
Invalid MIT-MAGIC-COOKIE-1 keyCan't open display :0

I cannot login as “jone”, but I can login as guest. I tried to delete ~/.Xauthority - no result. LightDM, Xfce. How to fix it?

Then I read about “xhost +” command, perhaps this could be a solution, but I don’t know to what file it is necessary to add this line :frowning:

That is not supposed to happen.

Have you rebooted recently?

I ask, because some updates to “systemd” can lead to problems, which are fixed by rebooting. If you have not rebooted recently, then try that.

Other possibilities:

Have you gone to the Yast security settings, and tightened security? (You may have tightened them too much).

Have you modified the PAM configuration? (If you disabled the systemd pam interface, that could cause such problems).

I forgot to add that it is my error: I tried different methods of start of the user session, such as adding ‘startxfce4’ in ~/.bash_profile and something like this. But now all these configuration files are deleted.

Have you rebooted recently?

twice))

Have you gone to the Yast security settings, and tightened security?

No.

Have you modified the PAM configuration?

Also no.

It a stupid mistake, but creating a new user is a hard way :\

You can just delete all of the configuration files. They have names that begin with “.”

I sometimes do:


mkdir OLD
mv .??* OLD

Then I look in the OLD directory, and maybe move a few back (such as “.mozilla” and “.thunderbird”)

I should add that I do this at a command line login (CTRL-ALT-F1 and then login at command line).

Next GUI login is a fresh start. And I can get the old config back from directory OLD if I deleted too much.

Here’s the problem with starting your x-session in “.bash_profile”. The X-session itself runs “.bash_profile” during startup. So you setup a recursive loop. And I guess that resulted in “.Xauthority” being clobbered.

Here’s the problem with starting your x-session in “.bash_profile”. The X-session itself runs “.bash_profile” during startup. So you setup a recursive loop. And I guess that resulted in “.Xauthority” being clobbered.

~/.bash_profile at once was moved to ~/.bash_profile.OFF …
Yes, it is necessary to potter with dotfiles - but they have no relation to a problem! For example

find ~ -type f -mtime -2

doesn’t show any changes in remaining configuration files

nrickert](https://forums.opensuse.org/member.php/49759-nrickert), I followed Your advice:

I sometimes do:
Code:
mkdir OLD
mv .??* OLD

mv -v /home/jone/.!.]* _DOT_OLD/

and then copied ALL dotfiles back - it works! But don’t understand how it works… black magic in Linux?

UPD, more detailed:
logout, login on another VC, move dotfiles, reboot, login in Xfce (Ok), logout, move files back, login - Ok.