logitech usb wireless keyboard

with the usb wireless keyboard after I shut down and reboot opensuse 12.3 the keyboard doesnt function till I unplug the usb dongle and wait for about one minute then replug dongle and it works.this is after three installs and a new kernel, the only thing I have succeeded in doing is getting hdmi working, anyone know what is wrong why this intermitent problem wont fix.
regards ron
new kernel 3.10.4-1.gd58862b-desktop

Tell us about your PC. How many USB ports and which ones if any are USB 3 and which ones are USB 2? Let me say right off that the behavior you mention out sounds like a USB 3 port is being used for your keyboard/mouse. If you have a USB 2 port, then use it. If you have a USB mouse keyboard compatabilty mode in your BIOS or UEFI PC setup, it needs to be enabled. If you don’t understand what I am talking about, you need to look up the complete specifications for your PC.

And as a new poster here, welcome to the openSUSE forums.

Thank You,

thanks for the reply jd I went into bios legacy support enabled I disabled it no help.this keyboard dongle will only work on usb3 port not on usb 2 port but in linux mint15 and ubuntu 13.04 the dongle works on usb 2.dongle only works on usb 3 on fedora 19 also.all these operating systems are on seperate hard drives.my motherboard is an asrock fatal1ty z87 professional,cpu is Intel® Core™ i7-4770K CPU @ 3.50GHz × 8 plus 32 gig of memory Idont know why its not working properly,the wireless mouse works ok on usb2 maybe some bug not sure using old cable keyboard to write this
regards Ron

ok @jd thanks you pointed me in the right direction it was the bios,usb 3 was on auto legacy was enabled so I disabled usb3,and put legacy usb on auto rebooted and did a dmesg in all 4 operating systems and it was all good thanks once again and your tutorial on installing new kernel worked for me.
regards Ron
ps after the first shot at the bios I gave up the about 3 hours later I gave it another shot just had to think about it

Happy you found a working BIOS or UEFI PC setting that worked for you. USB 3 ports are not the same as 2 and some legacy drivers are having problems at boot time it would seem.

Thank You,