Logitech USB Headset no sound

Hello everyone,

First off, this is my first post so I would like to congratulate everyone on doing a really great job of helping out beginners like me and teaching us how to diagnose and fix problems for ourselves. Everyone here seems really helpful and I only wish you all the best of luck and please continue to make this community as good as possible.

Now for my problem, on my laptop at home (Aspire 5750G - openSUSE 13.1 KDE) I have no problems whatsoever, the problem is with another desktop computer running also openSUSE 13.1 KDE. I have an Intel onboard sound card and one Logitech USB Headset (alongside a Logitech USB Webcam) connected. The thing is I can’t hear any system sounds (nor from any application, chrome, skype etc.), but I do hear sound picked up from the mic of the headset (i.e. I hear what I type or the sounds in the room).

Before you try to answer me please note that I did search this forum for a similar problem and tried the solutions mentioned, I also tried to do what it says here https://en.opensuse.org/SDB:Intel-HDA_sound_problems but nothing worked I’m afraid.
I don’t know very much about linux but I can post here whatever it is you want to see form my computer to check for a solution to my problem. I really like openSUSE, and except this sound problem, everything is fine and I do wish to continue using this distro.

In the hopes that someone is willing to help me out with this, I sincerely thank you all and wish you a great day!

Leonardo Cserny

Hi all,
I just wanted to let everyone know (if they are also having this problem) that I solved it myself :slight_smile:
What I did was go to Audio Setup in Kmix and changed the default for ALL categories there to the Logitech Headset and also added my model and position_fix to /etc/modprobe.d/50-sound.conf

All is well now, have a great day!

Leonardo Cserny