Logitech Trackball Doesn't Scroll

I just did a fresh install of 42.2. I have a Logitech Marblemouse trackball on which I emulate scrolling by using one of the buttons and the trackball. Under 42.1 I had a config file in the /etc/X11/xorg.conf.d directory, 11-mouse.conf which I had altered and seemed to do the trick for me. There was no 11-mouse.conf in that directory under 42.2, so I simply added it. No dice. I don’t get the scrolling to work. Here is my code:

    MatchProduct    "RX 250 Optical Mouse"    MatchIsPointer    "on"
    Driver    "evdev"
    Option    "Buttons"    "7"
    Option    "YAxisMapping"    "4 5"
    Option    "XAxisMapping"    "6 7"
EndSection


Section "InputClass"
    # 045e:0095
    Identifier    "Microsoft IntelliMouse Explorer"
    MatchVendor    "Microsoft Corp."
    MatchProduct    "IntelliMouse Explorer 4.0 (IntelliPoint)"
    MatchIsPointer    "on"
    Driver    "evdev"
    Option    "HWHEELRelativeAxisButtons"    "7 6"
EndSection


Section "InputClass"
    # 0210:0003
        Identifier      "0210:0003"
        MatchVendor     "0210"
        MatchProduct    "0003"
        MatchIsPointer  "on"
        Driver  "evdev"
        Option  "EmulateWheel"    "on"
    Option    "EmulateWheelButton"    "2"
EndSection


Section "InputClass"
    # 0002:000a
        Identifier      "0002:000a"
        MatchVendor     "0002"
        MatchProduct    "000a"
        MatchIsPointer  "on"
        Driver  "evdev"
        Option  "EmulateWheel"    "on"
    Option    "EmulateWheelButton"    "2"
EndSection


Section "InputClass"
    # 04b3:300f
        Identifier      "IBM 300f"
        MatchVendor     "IBM Corp."
        MatchProduct    "300f"
        MatchIsPointer  "on"
        Driver  "evdev"
        Option  "EmulateWheel"    "on"
    Option    "EmulateWheelButton"    "2"
EndSection


Section "InputClass"
        # Novell Bug #597214
        Identifier      "IBM TPPS/2 TrackPoint"
        MatchProduct    "TPPS/2 IBM TrackPoint"
        MatchIsPointer  "on"
        Driver  "evdev"
        Option  "EmulateWheel"  "on"
        Option  "EmulateWheelButton"    "2"
        Option  "YAxisMapping"    "4 5"
    Option    "XAxisMapping"      "6 7"
        Option  "Emulate3Buttons"    "on"
        Option  "EmulateWheelTimeout"    "200"
EndSection


Section "InputClass"
    # Novell Bug #668842
        Identifier      "PS/2 Generic Mouse"
        MatchProduct    "PS/2 Generic Mouse"
        MatchIsPointer  "on"
        Driver  "evdev"
        Option  "EmulateWheel"  "on"
        Option  "EmulateWheelButton"    "2"
        Option  "YAxisMapping"    "4 5"
        Option  "XAxisMapping"    "6 7"
        Option  "Emulate3Buttons"    "on"
        Option  "EmulateWheelTimeout"    "200"
EndSection


Section "InputClass"
        # Novell Bug #671776
        Identifier      "ImPS/2 Generic Wheel Mouse"
        MatchProduct    "ImPS/2 Generic Wheel Mouse"
        MatchIsPointer  "on"
        Driver  "evdev"
        Option  "EmulateWheel"  "on"
        Option  "EmulateWheelButton"    "2"
        Option  "YAxisMapping"    "4 5"
        Option  "XAxisMapping"    "6 7"
        Option  "Emulate3Buttons"    "on"
        Option  "EmulateWheelTimeout"    "200"
EndSection


Section "InputClass"
    # 03f0:1126
        Identifier      "HP 1126"
        MatchVendor     "Hewlett-Packard"
        MatchProduct    "1126"
        MatchIsPointer  "on"
        Driver  "evdev"
    Option    "MinX"    "0"
    Option    "MaxX"    "3000"
    Option    "MinY"    "0"
    Option    "MaxY"    "3000"
EndSection



This is the exact file that worked before. Is this controlled somewhere else in 42.2?

I’d really appreciate any help.

Thanks.

It is likely that libinput is being used (rather than evdev which is being deprecated). This thread may be of help to you with respect to configuring libinput to handle your touchpad as preferred…

https://forums.opensuse.org/showthread.php/521341-Logitech-Trackball-not-scrolling

Specifically…

Using libinput

As of version 3.16 GDM/Gnome uses libinput. For the device to work as described in the above section (note that wheel click emulation is not yet supported by libinput) you need to install xf86-input-libinput and instead append this to /etc/X11/xorg.conf.d/10-libinput.conf.
/etc/X11/xorg.conf.d/10-libinput.conf Section “InputClass”
Identifier “Marble Mouse”
MatchProduct “Logitech USB Trackball”
Driver “libinput”
Option “ScrollMethod” “button”
Option “ScrollButton” “8”
EndSection

Reference
https://wiki.archlinux.org/index.php/Logitech_Marble_Mouse#Using_libinput

Thanks. I appreciate it. I actually added the paragraph to the existing 60-libinput.conf file. I don’t have a 10-libinput.conf. In any case, it worked.

Glad to have been of help. You should really create a custom file with your preferred options as it will be overwritten if ‘xf86-input-libinput’ is updated.

[QUOTE=deano_ferrari;2802173]Glad to have been of help. You should really create a custom file with your preferred options as it will be overwritten if ‘xf86-input-libinput’ is updated.[QUOTE]

Good point. I moved the paragraph to a new file, 61-libinput.conf. Thanks again.