Logitech SqueezeBox - Installed but unable to launch it.

I’m using OpenSUSE 12.2.

I’ve downloaded the Logitech Media Server from Logitech’s website, to run my SqueezeBox.

I installed it by setting my Downloads folder (where the RPM is) as a repository in YaST, then asked YaST to install it, which went without problems.

When I went to launch it from the Kickoff Application Launcher, in KDE, I can’t find it. I have searched under Logitech and SqueezeBox. Using Dolphin, I have found a folder labelled Squeezeboxserver, under root/usr/share/squeezeboxserver. It contains folders labelled: Bin, CPAN, Firmware, Graphics, HTML, IR, Lib, MySQL, Plugins, and SQL, and files labelled: icudt46.dat, icudt46l.dat, revision.txt, and strings.txt.

How do I set it up so that I can launch it from KDE?

Thank you.

  1. Use yast2 to uninstall the rpm , you do not want to have this in root

  2. Download the source file something like logitechmediaserver-7.7.2.tgz

  3. Unpack into some folder under your home directory

  4. cd into this directory and open a console/terminal

  5. now run :

    perl slimserver.pl

    see what happens.

    Hopefully your perl installation has all it needs otherwise install
    any missing libraries see Installing Perl modules from CPAN - Learn how to install most Perl modules from CPAN in this tutorial.

    You might need to add some ports to your suse firewall setup

    use yast2 / security / firewall

    go to Allowed services and click on Advanced

    under TCP Ports you may need (besides what’s there) 3483 9000 9100
    under UDP Ports you may want 3483 631 9000 9100

    Press Ok, Next, Finish

    try to see if your server is connected now

    Ctrl-C kill if anything still running from the prev attempt
    or find it with ps ax|grep logi
    then kill (some pid number)

    In your terminal run:

    perl slimserver.pl --daemon

    Open a browser with this URL:

    Hopefully you see the server interface , press settings and take it from there

    (You may need to log into one of the logitech services to set the squeezebox up)

    I am running this for many years on opensuse (starting with 9.2 and now on 11.4)

    Once all is running you can put the server startup line perl … into a script
    to have it autostart on reboot.

    Hope this gives you some pointers…

Have you tried this squeezebox 7.7.1 startup in opensuse 12.1

Thank you for your replies.

Darkblue2, I’ll try your solution when I get time.

anika200, I saw that, but it looks way too complicated for me.

There’s also a four page discussion starting at opensuse 12.2 fails to run logitechmediaserver-7.8.0-0.1.1347896053 but it, too looks too complicated for me.

I do hope that Darkblue’s solution works for me. If it doesn’t, then I’ll have to see if I can find a friendly geek who can translate the other ones.

I’ll let you know how I go.

Thanks again.

Wow, this is way more complicated than I would normally want. Please let us know how you make out.

I have been trying to install

with very little luck. You can see a list of modules needed here slim - Revision 33997: /7.7/trunk/vendor/CPAN. There is also a buildme.sh file which should build all the modules needed but I have not been able to build them. If someone can tell me how to use the buildme.sh script from the above link site, I would appreciate the favor.

I have also tried to get the modules installed via cpan:> This was successful for EV not other requirements. Maybe I should learn to use cpan?

Darkblue2, I have had a go at following your suggestion. Here is the result:

[QUOTE=Darkblue2;2501211]1) Use yast2 to uninstall the rpm , you do not want to have this in root

  • Done
  1. Download the source file something like logitechmediaserver-7.7.2.tgz
  • Done
  1. Unpack into some folder under your home directory
    - Done. /home/LOGITECH

  2. cd into this directory and open a console/terminal
    - Done (within Dolphin)

  3. now run :

    perl slimserver.pl

    see what happens.
    **- This is where I come unstuck. This is what I did: In Dolphin, I opened the folder /Home/LOGITECH. This revealed a folder entitled logitechmediaserver-7.7.2-33893. While still in the /Home/LOGITECH folder, I right clicked and selected Actions/Open Terminal Here. This opened a terminal, which said: **

**I typed perl slimserver.pl, and this is the result:

**Home@linux-2xre:~/LOGITECH> perl slimserver.pl
Can’t open perl script “slimserver.pl”: No such file or directory

**Obviously unsuccessful. So, in Dolphin, I opened the /Home/LOGITECH/logitechmediaserver-7.7.2-33893 folder. This revealed ****a whole bunch of files and folders. I ****right clicked, opened a terminal, and tried again. This time the result was:

**Home@linux-2xre:~/LOGITECH/logitechmediaserver-7.7.2-33893> perl slimserver.pl
The following modules failed to load: DBI EV JSON::S YAML::S Sub::Name


If you’re running some unsupported Linux/Unix platform, please use the buildme.sh
script located here:

slim - Revision 33997: /7.7/trunk/vendor/CPAN

If 7.7 is outdated by the time you read this, Replace “7.7” with the major version
You should never need to do this if you’re on Windows or Mac OSX. If the installers
don’t work for you, ask for help and/or report a bug.

of Logitech Media Server you are running.


**I went to **slim - Revision 33997: /7.7/trunk/vendor/CPAN and found a buildme.sh file, but I’m reluctant to do anything with it, till I know some more (as you’ve guessed by now, I’m command line challenged - despite the fact that I’ve been using Linux since Caldera 3.1).

I’ve read the Installing Perl modules from CPAN** link that you gave me, but I’m not sure if it is appropriate here.

What should I do next? I’m conscious that there’s more to you post, but I’m a bit scared to try any more of it till this is resolved.

Thank you.**