Logitech Quickcam not working, opensuse 11.3


lsusb

046d:08af Logitech, Inc. QuickCam Easy/Cool

Apparently, this webcam uses the gspca2 driver. The gspca modules are loaded but if I try using a program like cheese it tells me no device was detected.


hwinfo --usb

17: USB 00.0: 11200 TV Card
  [Created at usb.122]
  Unique ID: YccR.9AtOl3Z230E
  Parent ID: uIhY.kllrQr_lFX9
  SysFS ID: /devices/pci0000:00/0000:00:02.0/usb3/3-9/3-9:1.0
  SysFS BusID: 3-9:1.0
  Hardware Class: tv card
  Model: "Logitech TV Card"
  Hotplug: USB
  Vendor: usb 0x046d "Logitech, Inc."
  Device: usb 0x08af 
  Revision: "1.00"
  Driver: "zc3xx"
  Driver Modules: "gspca_zc3xx"
  Speed: 12 Mbps
  Module Alias: "usb:v046Dp08AFd0100dcFFdsc00dp00icFFiscFFipFF"
  Driver Info #0:
    Driver Status: gspca_zc3xx is active
    Driver Activation Cmd: "modprobe gspca_zc3xx"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (Hub)

If I do a modprobe -rf gspca_zc3xx and then modprobe gspca_zc3xx I see the light blink a couple times, but it still doesn’t work in cheese.

I’ve looked around various forums but couldn’t find a solution. I don’t know where to go from here.

my guess is to use v4l1
and use this command to run cheese:
env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese

Thank you, I appreciate the help. I’m running 64 bit, so I had to modify the command accordingly.


env LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so cheese

It works great now.

Because Skype is only available for the 32 bit platform, I had to install the 32 bit libv4l package and load it with this command.


LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

Once I did that, the video worked. I wonder why skype is resisting 64 bit so much. Already, most systems sold are 64 bit capable. Most systems have 4GB of ram or more. It’s inevitable that they’ll need to create a 64 bit version. I just wish they’d do it sooner than later.

Thanks for the thread and solution! Have been trying to get this going for a while and now all good! but… How do we get this to work through a boot?
If Skype is running when you shutdown, it will automatically restart on boot, so trying to put something like this in the “autostart” section ends up with something like “Skype is already running”…
Thanks, John.