Logitech Mouse MX518

All the buttons on the mouse are not working and i want most of them to work. In Firefox and Thunar the back button works (side button) but it does not with all programs, also the Acceleration does not seem to stick, (some days it feels slow, some if feesl fast) i know its me right. >:( I’m using openSUSE 11.2 Gnome and KDE are install i use Gnome most of the time. Here is what the Yast Hardware tool reports for my mouse.

67: USB 00.0: 10503 USB Mouse
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_46d_c051_noserial_if0
Unique ID: cEJe.x4mVBir0QaE
Parent ID: pBe4.kllrQr_lFX9
SysFS ID: /devices/pci0000:00/0000:00:02.0/usb2/2-7/2-7:1.0
SysFS BusID: 2-7:1.0
Hardware Class: mouse
Model: “Logitech USB-PS/2 Optical Mouse”
Hotplug: USB
Vendor: usb 0x046d “Logitech, Inc.”
Device: usb 0xc051 “USB-PS/2 Optical Mouse”
Revision: “30.00”
Compatible to: int 0x0210 0x0018
Driver: “usbhid”
Driver Modules: “usbhid”
Device File: /dev/input/mice (/dev/input/mouse0)
Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event0, /dev/char/13:64, /dev/input/by-id/usb-Logitech_USB-PS_2_Optical_Mouse-event-mouse, /dev/input/by-path/pci-0000:00:02.0-usb-0:7:1.0-event-mouse, /dev/char/13:32, /dev/input/by-id/usb-Logitech_USB-PS_2_Optical_Mouse-mouse, /dev/input/by-path/pci-0000:00:02.0-usb-0:7:1.0-mouse, /dev/char/13:63
Device Number: char 13:63 (char 13:32)
Speed: 1.5 Mbps
Module Alias: “usb:v046DpC051d3000dc00dsc00dp00ic03isc01ip02”
Driver Info #0:
Buttons: 8
Wheels: 1
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #65 (Hub)

85: udi = ‘/org/freedesktop/Hal/devices/usb_device_46d_c051_noserial_if0_logicaldev_input’
linux.hotplug_type = 2 (0x2)
linux.subsystem = ‘input’
input.device = ‘/dev/input/event0’
input.product = ‘Logitech USB-PS/2 Optical Mouse’
input.x11_driver = ‘evdev’
info.subsystem = ‘input’
info.product = ‘Logitech USB-PS/2 Optical Mouse’
info.udi = ‘/org/freedesktop/Hal/devices/usb_device_46d_c051_noserial_if0_logicaldev_input’
input.originating_device = ‘/org/freedesktop/Hal/devices/usb_device_46d_c051_noserial_if0’
linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:02.0/usb2/2-7/2-7:1.0/input/input0/event0’
info.parent = ‘/org/freedesktop/Hal/devices/usb_device_46d_c051_noserial_if0’
info.capabilities = { ‘input’, ‘input.mouse’ }
info.category = ‘input’
linux.device_file = ‘/dev/input/event0’

149: udi = ‘/org/freedesktop/Hal/devices/usb_device_46d_c051_noserial’
info.vendor = ‘Logitech, Inc.’
linux.hotplug_type = 2 (0x2)
linux.subsystem = ‘usb’
info.linux.driver = ‘usb’
usb_device.linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:02.0/usb2/2-7’
usb_device.configuration_value = 1 (0x1)
usb_device.num_configurations = 1 (0x1)
usb_device.num_interfaces = 1 (0x1)
usb_device.device_class = 0 (0x0)
usb_device.device_subclass = 0 (0x0)
usb_device.device_protocol = 0 (0x0)
usb_device.vendor_id = 1133 (0x46d)
usb_device.product_id = 49233 (0xc051)
usb_device.vendor = ‘Logitech, Inc.’
info.subsystem = ‘usb_device’
info.udi = ‘/org/freedesktop/Hal/devices/usb_device_46d_c051_noserial’
usb_device.max_power = 98 (0x62)
usb_device.product = ‘G3 (MX518) Optical Mouse’
usb_device.num_ports = 0 (0x0)
usb_device.linux.device_number = 2 (0x2)
info.product = ‘G3 (MX518) Optical Mouse’
usb_device.device_revision_bcd = 12288 (0x3000)
usb_device.version = 2.00000
usb_device.speed = 1.50000
usb_device.can_wake_up = true
usb_device.is_self_powered = false
linux.device_file = ‘/dev/bus/usb/002/002’
usb_device.bus_number = 2 (0x2)
linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:02.0/usb2/2-7’
info.parent = ‘/org/freedesktop/Hal/devices/usb_device_1d6b_1_0000_00_02_0’
info.capabilities = { ‘access_control’ }
access_control.file = ‘/dev/bus/usb/002/002’
access_control.type = ‘mouse’

----- /proc/bus/input/devices -----
I: Bus=0003 Vendor=046d Product=c051 Version=0110
N: Name=“Logitech USB-PS/2 Optical Mouse”
P: Phys=usb-0000:00:02.0-7/input0
S: Sysfs=/devices/pci0000:00/0000:00:02.0/usb2/2-7/2-7:1.0/input/input0
U: Uniq=
H: Handlers=mouse0 event0
B: EV=17
B: KEY=ff0000 0 0 0 0
B: REL=103
B: MSC=10

bus = 3, name = Logitech USB-PS/2 Optical Mouse
handlers = mouse0 event0
key = 0000000000ff00000000000000000000000000000000000000000000000000000000000000000000
rel = 0000000000000103
mouse buttons = 8
mouse wheels = 1

But this is what my xorg conf has in it.

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

I was wondering about if i change it to this will it work.

Section “InputDevice”
Driver “evdev”
Identifier “Mouse0”
Option “Buttons” “9”
Option “Name” “Logitech USB-PS/2 Optical Mouse”
Option “ButtonMapping” “1 2 3 6 7 8 9”
Option “ZAxisMapping” “4 5 6 7”
EndSection

I do not know what Option “Protocol” “auto” means and the one from the xorg conf has mouse as a driver will the evdev work?

I really dont want to mess up my xorg conf because i have dual screens and its work good right now and i have a wierd thing going on in KDE and thats 2 different destops (yes i can change the desktop background for both screens and make them different). Thats another post coming not this one.

I have had problems with just about all Ubuntu versions once i install the Nvidia drivers and i just really like the way openSUSE is laid out and a polished OS it just seems to work. :slight_smile:

You can set the basic mouse definitions KDE’s systemsettings tool. For additional functions you have to modifiy the configuration files in /etc/X11/xorg.conf.d/ manually. But first you should upgrade to openSUSE 11.3 without an /etc/X11/xorg.conf file.

Hi Boenis :slight_smile:

I’m really new here, so please excuse my ignorance. I have recently installed openSuse 11.3 - 32 bit, and I have a Logitech MX510 usb mouse. I would love to configure my mouse.conf file properly so that all the buttons work on the mouse in KDE. When I use Firefox or Chromium the side buttons work fine, but not in KDE.

I am capable of editing the conf file with vi, but I don’t know what information I have to add to make all the buttons work. I tried one configuration and it stopped KDE from booting normally, so I removed that one :wink:

Could you (or somebody else) possibly point me in the right direction please?

Many thanks and kind regards :slight_smile:

You may have to wait for the side buttons to work. While looking at the KDE 4.7 SC Features, I found a bullet to “Support Fwd/Back Mouse Buttons” in Dolphin.

So maybe Real Soon Now…

Fingers crossed :wink: Thanks for the reply :slight_smile:

Any update to this.

Do the fwd / back mouse buttons now work? If so what needs to be done to enable them? Not sure of my mouse model but it is Wireless Logitech.

Found a page here that might do it.

Logitech Mouse

A system update got it working. Well most of it. Good enough for now. I’ve got the fwd / back buttons working.