Logitech EX110 Mouse and Xorg.conf question

Okay, I’m a relative linux newbie (much help from these forums but this is my first post) and am currently using suse 11.0 with KDE 3.5.9 on a laptop. I just purchased a Logitech EX110 usb wireless keyboard and optical mouse. The keyboard worked right out of the box, but I’m having trouble setting up the mouse.

I have tried doing the configuration through the yast gui. However, my specific mouse model is not under the logitech section, and whenever I try to test a configuration the sax2 mouse model configuration screen hangs, and I can’t access it again until I reboot the computer (kill didn’t work either).

So I figure I’m going to have to edit the Xorg.conf by hand. I have also read that I should be editing the XF86Config file, so some advice there would be helpful. Below is a snippet of (what I gather to be the relevant sections of my) Xorg.conf file.

Section “ServerLayout”
Identifier “Layout[all]”
Screen 0 “aticonfig-Screen[0]” 0 0
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
EndSection

. . .

Section “InputDevice”
Identifier “Mouse[1]”
Driver “synaptics”
Option “AccelFactor” “0.01”
Option “BottomEdge” “650”
Option “CircScrollDelta” “0.1”
Option “CircScrollTrigger” “2”
Option “CircularScrolling” “1”
Option “Device” “/dev/input/mice”
Option “EdgeMotionMaxSpeed” “15”
Option “EdgeMotionMinSpeed” “15”
Option “Emulate3Buttons” “on”
Option “EmulateMidButtonTime” “75”
Option “FingerHigh” “15”
Option “FingerLow” “14”
Option “HorizScrollDelta” “20”
Option “LeftEdge” “120”
Option “MaxSpeed” “0.5”
Option “MaxTapMove” “110”
Option “MaxTapTime” “180”
Option “MinSpeed” “0.2”
Option “Name” “Touchpad”
Option “Protocol” “auto-dev”
Option “RightEdge” “830”
Option “SHMConfig” “on”
Option “TopEdge” “120”
Option “UpDownScrolling” “1”
Option “Vendor” “ALPS”
Option “VertScrollDelta” “20”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Identifier “Mouse[3]”
Driver “synaptics”
Option “AccelFactor” “0.01”
Option “BottomEdge” “650”
Option “CircScrollDelta” “0.1”
Option “CircScrollTrigger” “2”
Option “CircularScrolling” “1”
Option “Device” “/dev/input/mice”
Option “EdgeMotionMaxSpeed” “15”
Option “EdgeMotionMinSpeed” “15”
Option “Emulate3Buttons” “on”
Option “EmulateMidButtonTime” “75”
Option “FingerHigh” “15”
Option “FingerLow” “14”
Option “HorizScrollDelta” “20”
Option “LeftEdge” “120”
Option “MaxSpeed” “0.5”
Option “MaxTapMove” “110”
Option “MaxTapTime” “180”
Option “MinSpeed” “0.2”
Option “Name” “Touchpad”
Option “Protocol” “auto-dev”
Option “RightEdge” “830”
Option “SHMConfig” “on”
Option “TopEdge” “120”
Option “UpDownScrolling” “1”
Option “Vendor” “ALPS”
Option “VertScrollDelta” “20”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Identifier “Mouse[5]”
Driver “mouse”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

I don’t know why there are three mice set up in this file. Can I safely delete any of these entries? Under the yast gui there are three tabs, though the ‘activate this pointer’ check box is only checked for the first ALPS touchpad. From what I have read I should probably try to use the evdev driver for the new mouse? Also, the mouse itself is a three button wireless mouse with one of the buttons as a clickable scroll wheel. I would be happy to provide any more info if it would be helpful.

Apparently the mouse works when I boot into Failsafe mode. I recently added an external monitor to my setup and changed the drivers for my graphics card. When my desktop is running just on my laptop screen (in failsafe) the mouse works. Don’t know why I think it’s the graphics/monitor/cloned desktop settings, but I set them up using ati-config from the command line rather than editing my xorg. Felt like an ugly workaround is all.