Logitech c310 webcam audio not working

Hi everyone

I am running openSUSE 13.2 (x64) KDE desktop; I just bought a Logitech c310 webcam.

I tested it using Google-Talk from my browser (Firefox). My friend on the other end couldn’t hear anything!

So I started to dig a little…,

Output of ‘lsusb’ shows

Bus 002 Device 003: ID 046d:081b Logitech, Inc. Webcam C310

One guy at this Ubuntu forum suggested

All I had to do was going into System/Preferences/Sound/Input and choose the Analog Mono option. Doh!

Another guy at Logitech forum also suggested

open a terminal
type alsamixer
hit enter
adjust your mic db levels
ubuntu comes up muted at start up

Almost convienced that I had the same problem lol!

typed ‘alsamixer’ in terminal

pressed ‘F6’ to select ‘USB device’

pressed ‘F4’ to show ‘Capture’ device

But mic db gain was already 30!! :disapointed:
‘Capture’ was also on… as far as I could tell! :dont-know:

Finally found this very helpful posting on openSUSE forum about arecord.

I had to record with the following settings

arecord -f S16_LE -c1 -r16000 -D hw:2,0 -d 5 test.wav

You see I specifically had to metion the exact format, exact number of channels, exact sample rate, exact card number, otherwise arecord threw all kinds of error messages.

But that’s about it, Cheese (app) still records video without audio

I am guessing may be the exact sample rate and formats should be changed in some config file somewhere?? or something else?? :confused:

Can someone please save my day…

Thanks in advance

BTW, this is a dual boot machine, and everything worked out fine under Win-7(x64).

Hi everyone

I think I fixed it…


and then did this, went to

Configure Desktop > Multimedia

from the top left hand corner clicked ‘Audio and Video Settings’

under the ‘Device Preference’ tab, clicked ‘Recording’ (under Audio Recording)

then using the (Prefer/Defer) buttons at bottom right hand corner, put the audio device of my choice (Webcam C310 Analog Mono) to the the top of the list.

and voila!! Cheese now records both audio & video…

Will test it with Google-Talk later tonight, until then, fingers crossed :smiley:


Just an update (as promosed) :smiley:

Works fine with Google talk.