Logitech Anwhere Mouse shows strange behavior

Hello, I’m using a Logitech Anywhere laser mouse connected to my notebook running openSUSE Tumbleweed. However since a few upgrade I feel like there is a strange behavior.

When I start my notebook with the receiver plugged into the USB and I want to move the mouse it take some seconds for the mouse to react. First of all I thought it’s the power saving feature for the USB but I have the notebook running with cable power connection, not on battery. To solve the problem I have to unplug the usb and plug it in again. Sometimes I have even to restart the computer.

Next strange thing is that I when I’m using Libre Office and I click in the Taskbar (KDE) and switch back to Libre Office I cannot scroll anymore. I have to switch to for example Firefox or Dolphin and then back to Libre Office to make it work again. Sometimes I have to additionally minimize Libre Office and maximize it again to make the scrolling feature of the mouse work again.

Is somebody is aware of this problem. Any information concerning this problem would be appreciated.

Thank you very much.

It’s hard to diagnose at a distance. So I’ll just describe issues that I have had.

I’m using a Logitech M325 (that’s an LED mouse). Most of the time, it works fine. But, occasionally, it just stops working. So I shake the mouse, and it starts working again. I’m suspecting that the pressure between the battery terminals and the spring terminal on the mouse is a tad to small. And, with the constant mouse motion, it sometimes gets a poor electrical connection, so behaves as if there is no battery.

I’m using the M325 on my main desktop. I also use one with my laptop. On my main desktop, I originally plugged the receiver into a USB port at the back of the tower. And it was sluggish, something like what you describe. I now plug it into the front of the tower, and it works a lot better. My best guess is that the wireless path to the back port was a bit too long, and there was perhaps some electrical noise. And the computer tower, with it’s metal, was perhaps a bit of a wireless shield. Using the front USB port solved that problem.

Thank you for your reply.

I know it’s difficult to find out from the distance. I’m using the usb receiver 10 cm away from the mouse as it’s a notebook computer.
I thought that it maybe has to to with the power saving features of opensuse. Recently it works better than before.

The second problem is when I click in the notification bar at the bottom right where also the watch is in KDE and I go back to libre office I cannot scroll until I minimize Libre Office and maximize it again. This only happens when using the mouse. When using the touch pad it works perfectly.

It seems that there is something wrong with KDE or in Libre Office. Firefox, Kwrite and other programs do work (only Libre Office is affected)

it’s a little bit difficult to explain I know.

Okay. I use LibreOffice so rarely, that I would not know whether I am affected by the same problem.


I use LO quite heavily and don’t have any issue with scrolling.

LO V5., using a Logitech USB Laser Mouse (wired connection).

Ok thank you very much for the help.

I guess it has something to do with Libre Office.

I finally found out that both the mouse and the mouse pad are affected. I’m using the laser mouse but with this unifying connecting bluetooth dongle.
And I use the touchpad with the finger scrolling feature (2 fingers down or up no matter where I place them on the touchpad).

However when I do something in the taskbar (eg connection wifi or the calendar) and switch back to Libre Office, scrolling with the mouse does not work at all and when using the touchpad it’s very slow and stuttering somehow. So very choppy scrolling.

As I’m using Libre Office quit often its pretty annoying to switch first to Firefox and then back to Libre Office as there are 2 more clicks involved.

Libre Office Version is and as I can remember this didn’t happen before.

Should I ask better at Libre Office helps as it seems that other programs work?


I dont know if this applies to this case but the Logitech Anywhere mouse does have hardware issues of its own. I am on my second one noew having had the first replaced by Logitech. After some time using it the mouse can start behaving badly often the initial problem can be with double clicks where you only intend to do one. Sometimes replacing the battery will sort it for a short while, others suggest removing the battery and clicking the buttons several 10’s or 100’s of times before replacing the battery, however in my experience this may only fix the issue for a short time. This seems to be a well known issue with this mouse. The only way I fixed mine was to get it replaced, however I worry the bug will re-appear as it seems to be a design issue.


Thank you very much. Yeah I know the built quality of Logitech products is constantly going downwards during the last years. I remember times (maybe 10 - 15 years ago) where all of the products worked for years without a problem.

Then I had the desktop laser mouse mx which was broken 2,5 years ago (half year after the warranty ended). Their old mice where more reliable (7-8 years of usage).

That’s the reason I bought for my desktop the g403 mouse recently which is very expensive but as it is intended for gaming maybe the built quality is better now. They advertised that you can click 2 million times but then the battery is not replaceable.

Back to the topic.

The anywhere mouse I use only occasionally as I’m fine using the touchpad for most operations. But I have to write a lot in Libre Office during the last time and for me it’s easier to do it with mouse. I have to drag and drop sentences around different pages and scroll up and down. For me the workflow is much better with a mouse.

I will write on the Libre Office mailing list an see what they say there. My problem only happens after using the taskbar and switching back to Libre Office.