Logitech AK5370 Mic Problem

Running Suse 11.0. I have a Logitech AK5370 USB microphone and I can’t get it working. Yast recognizes it. Can’t get it to work in any recording software or Skype. Skype recognizes it, but does not record during the test. Yast recognizes it and shows the snd-usb-audio driver.

Everything looks perfect, still nothing. Tried Kmix, Alsamixer and the Xfce mixer. Can’t figure out what I’m doing wrong.

Here are some outputs that may help:

Bus 002 Device 004: ID 0556:0001 Asahi Kasei Microsystems Co., Ltd AK5370 I/F A/D Converter

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
01:06.0 Communication controller: Conexant Device 2f40
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)

6: udi = ‘/org/freedesktop/Hal/devices/usb_device_556_1_noserial_if1’
info.subsystem = ‘usb’
usb.num_interfaces = 2 (0x2)
usb.can_wake_up = false
linux.subsystem = ‘usb’
usb.linux.device_number = 4 (0x4)
info.linux.driver = ‘snd-usb-audio’
usb.interface.number = 1 (0x1)
info.product = ‘USB Audio Interface’
usb.vendor = ‘Asahi Kasei Microsystems Co., Ltd’
usb.device_class = 0 (0x0)
usb.interface.class = 1 (0x1)
info.udi = ‘/org/freedesktop/Hal/devices/usb_device_556_1_noserial_if1’
usb.bus_number = 2 (0x2)
usb.interface.subclass = 2 (0x2)
usb.product = ‘USB Audio Interface’
usb.device_subclass = 0 (0x0)
usb.interface.protocol = 0 (0x0)
usb.linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:02.0/usb2/2-9/2-9:1.1’
usb.speed = 12.0000
usb.device_revision_bcd = 1 (0x1)
usb.device_protocol = 0 (0x0)
linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:02.0/usb2/2-9/2-9:1.1’
usb.configuration_value = 1 (0x1)
usb.version = 1.10000
info.parent = ‘/org/freedesktop/Hal/devices/usb_device_556_1_noserial’
usb.max_power = 90 (0x5a)
usb.vendor_id = 1366 (0x556)
usb.num_configurations = 1 (0x1)
usb.is_self_powered = false
usb.num_ports = 0 (0x0)
usb.product_id = 1 (0x1)
linux.hotplug_type = 2 (0x2)

Thanks for the outputs, but I confess there is a lot there and not much wrt the specifics of your sound configuration.

I note this:

And that USB info that you added is way above my “paygrade” (which as a volunteer to this form is absolutely zero). :slight_smile:

Anway, can you provide some more (different) information? Specifically, with your PC connected to the internet, please copy and paste the following into a gnome-terminal or konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Once you have posted that information, someone else, or possibly myself, may be able to provide a helpful recommendation(s).

Probably doing nothing wrong. USB devices can be notoriously difficult to configure with Linux (and not just openSUSE). Sometimes they “just work”, and sometime they are a “bear” to get working. Sometimes one distribution will handle USB device A easily, and not device-B, while another distribution will handle USB device B easily, but not device-A. …

When I test my mic, I typically use a simple arecord command. ie something likearecord -d 10 myrecording.wavor
arecord -d 10 -f cd secondrecording.wavwhere “-d 10” sets a 10 second recording. I then play back the recording “myrecording.wav” or “secondrecording.wav” with xine or mplayer or xmms (or any audio playback program). I typically test the mic with different mixer settings until I find the one that works.

Another good basic test for one’s mic is to type this in a gnome-terminal or konsole:arecord -f cd -vv /dev/nullthen talk into your mic and watch the volume “meter”, adjusting your mixer as appropriate such that you get movement on the meter. Press <CTR><C> to stop the arecord.

Glad to have volunteers helping users. Your help is greatly appreciated.

Here are the results of the commands given:

tsalsa.txt - nopaste.com (beta)

rpm -qa | grep alsa
alsa-plugins-1.0.16-57.1
alsaplayer-0.99.80-1.pm.1
alsa-tools-1.0.16-47.1
alsa-firmware-1.0.16-24.1
alsa-oss-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-plugins-jack-1.0.16-57.1
alsa-1.0.16-39.1

rpm -qa | grep pulse
Pulse is not installed

rpm -q libasound2
libasound2-1.0.16-39.1

uname -a
Linux linux-oumh 2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200 i686 athlon i386 GNU/Linux

cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

CvwD.+_Jx4MBeSu2:MCP61 High Definition Audio

alias snd-card-0 snd-hda-intel

From that I note:

Alsa cards:         
         0 [NVidia         ]: HDA-Intel - HDA NVidia        
                              HDA NVidia at 0xfe024000 irq 22        
         1 [U0x46d0x8b4    ]: USB-Audio - USB Device 0x46d:0x8b4        
                              USB Device 0x46d:0x8b4 at usb-0000:00:02.0-10, full speed        
         2 [default        ]: USB-Audio - AK5370                  
                              AKM              AK5370           at usb-0000:00:02.0-9, full speed  

With 3 devices detected:

  • card 0 an ALC888 (HDAIntel) - your motherboard sound device is my guess
  • card 1 an 046d:08b4 logictec webcam (this model not supported I suspect)
  • card 2 your usb microphone - AKM AK5370

I was considering a custom edit to /etc/modprobe.d/sound, but before I considered that too much, I happened to stumble across a Ubuntu thread. Take a look at post#5 in this thread:
[SOLVED] Logitech AK5370 USB microphone - Ubuntu Forums](http://ph.ubuntuforums.com/showthread.php?t=575078)

They created a custom .asoundrc file under /home/username

pcm.lydkort&mic {
type asym
playback.pcm {
type plug
slave.pcm "hw:0,0"
}
capture.pcm {
type plug
slave.pcm "hw:1,0"
}
} 

You could try that in your /home/username dierctory. Restart your alsa after making and saving that file: su -c 'rcalsasound restart’

Hopefully other edits will not be necessary.

Well, that didn’t work. I’m thinking that the default capture device is set to either the mic input in the back (on the motherboard) or the mic input on the front. However, I don’t know how to change the default capture device.

I have now tried a standard mic and plugged into the mic ports on front and back. If I speak into the mic the sound comes out of my speakers, but no sound recorder or sound meter of any kind shows that there is any output from the mic. At this point, no mic works at all.

Did you try this … which is to type this in a gnome-terminal or konsole:arecord -f cd -vv /dev/null
and while that is running (and visible) open your mixer and try different settings.

Odd, very odd. I installed Audacity and I can use the USB mic to record. I’m confused.

I did plug into a different USB port. Let me try Skype again.

Testing…

I don’t see anywhere to select the USB mic through Skype.

Test Failed.

Trying asound.

Testing…

Command: arecord -f cd -vv /dev/null

No reaction.

Test Failed.

Trying Kmix.

Selected USB mic as capture device.

Testing…

No reaction from asound. No change in Skype.

Test Failed.

Your settings from before have:

Amixer contents for card 0 [NVidia] _____________________________________
amixer set ‘Front Mic’,0 81%,81% on
amixer set ‘Front Mic Boost’,0 67% 67%
amixer set ‘Mic’,0 58%,58% on
amixer set ‘Mic Boost’,0 33% 33%
amixer set ‘Capture’,0 Capture 11 35%,Capture 11 35% on
amixer set ‘Capture’,1 Capture 16 52%,Capture 16 52% on
amixer set ‘Input Source’,0 Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘Aux’ Item0: ‘Aux’
amixer set ‘Input Source’,1 Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘Aux’ Item0: ‘Line’
ie you have no mic selected, only “aux” (for source 0) and “line” (for source 1) selected.

Congratulations on getting the USB mic to work with audacity.

Reference your motherboard sound, … you have an ALC888 on the motherboard. The ALSA-Configuration.txt file has these options for the ALC888:

	ALC883/888
	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
	  6stack-dig-demo  6-jack digital for Intel demo board
	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810
	  medion	Medion Laptops
	  medion-md2	Medion MD2
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  haier-w66	Haier W66
	  6stack-hp	HP machines with 6stack (Nettle boards)
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  auto		auto-config reading BIOS (default) 

To get your motherboard mic working, you may need to specify one of those options.

Possible settings (for motherboard sound/mic, not usb) would be to edit your /etc/modprobe.d/sound file, changing it to:
options snd slots=snd-hda-intel

CvwD.+_Jx4MBeSu2:MCP61 High Definition Audio

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

and then restart alsa with su -c ‘rcalsasound restart’ and test your mic. If “model=auto” does not work, repalce auto with “6stack-dig” or one of the other many options, restarting alsa for each attempt.

I think there is not much more I can do to help. You have proven the mic works under Linux. Now IMHO its a matter of tuning your configuration, and to provide help there, I think you need it from someone with a similar device (of which I have no such device - I simply use an old PC - the wife promises I get a new PC in December ).

Good luck!

So how and with what do I select different devices? I guess I have been trying too long. I’m completely lost now.

Thanks for trying. Looks like I will have to set this up in Windows. I have to go on a business trip and want to be able to video chat with my girlfriend. I am running out of time.

It’s times like this when I think Linux is really annoying.

OMG! I don’t know what I did, but it’s working now. Perhaps Audacity changed something when I chose the USB mic and closed it.

Geeze, what a pain.

Thanks everyone for all the help.

Have a good week.

:slight_smile:

You will need to post a screen print of your mixer. For example, on my mixer …
http://img300.imageshack.us/img300/84/kmix1qi1.th.jpg](http://img300.imageshack.us/my.php?image=kmix1qi1.jpg)http://img300.imageshack.us/images/thpix.gif](http://g.imageshack.us/thpix.php)
you can see it is VERY intuitive.

If you are using KDE4 then dependent on the mixer, you can add extra control options under the menu item “settings” in the mixer.

OK, congratulations.

May I recommend next time you take notes of what you try. That is what I do. Otherwise it is pure chaos, and the benefit of a lot of the time spent trying to figure something out can be lost in the “fog and confusion of the chaos”.

One more thought … if and when you get the chance, for anyone following this thread, other than “install audacity” it is not possible to tell what your configuration (or solution) might be.

Do you still have the custom .asoundrc file in place?

Did you apply a model option to your /etc/modprobe.d/sound file?

What are your exact mixer settings? (if you can run that diagnostic script again, it will provide that info).

Congratulations again, and if you get the chance, answering the above might be helpful to any other openSUSE users who try to follow your success.

Good point. I wish I had taken better notes in case it stops working.

  1. Installed Audacity from repositories. Chose AK5370 USB device as capture device. Recorded voice. Test successful.

  2. Do have custom .asoundrc file in place. Do not know of it’s efficacy.

  3. Script results: tsalsa.txt - nopaste.com (beta)

Notes:

Tried several mixers to enable USB mic. Kmix seem the only one that actually “see” the USB mic.

Set AK5370 as a capture device in Kmix.

Moved mic to a different USB port.

Closed and re-opened Skype after each test.

Possible Conclusions:

  1. Audacity configuration may have enabled configurations and subsystems allowing USB mic to function properly.

  2. Kmix setting may have performed this function.

  3. Moving the mic to a different port (front to back) may have made a difference.

The custom .asoundrc configuration does not seem to have helped. I believe the the options: slave.pcm “hw:1,0” and slave.pcm “hw:1,0” are incorrect for this configuration. I could be wrong.