Login sound/libcanberra not working

In case you don’t already know, I’m running 11.4 x64 with GNOME. :wink:

I had a realization recently that my computer doesn’t make any login or logoff sounds. After some investigation, I’ve found there are two problems:

  1. The command for the login sound defaults to a sound that doesn’t exist; the id is “desktop-login”, but no desktop-login.oga exists in /usr/share/sounds/freedesktop/stereo. There does exist service-login.oga, however.

  2. Even with explicitly setting the path on canberra-gtk-play, no sound plays. The command hangs for a couple seconds and produces no errors, suggesting that it does find the sound, but nothing comes out of the speakers.

I’m not terribly desperate to get login sounds working, but I am confused about why this wouldn’t work out of the box.

That is strange… I was looking at my system and I have the sound file desktop-login.oga under /usr/share/sounds/freedesktop/stereo/
-rw-r–r-- 1 root root 17274 Feb 18 22:39 service-login.oga