Login session setup on openSuse 11.1 - Where?


Where is the login session setup in openSuse 11.1?

I just installed the system and I cannot see in the Configuration Pannel, the login session setup.
I want to put the login session equal openSuse 11.0. I didn’t like the new one.
How can I make this?

Thanks for the support.

douglascaixeta wrote:

> Hi,
> Where is the login session setup in openSuse 11.1?
> I just installed the system and I cannot see in the Configuration
> Pannel, the login session setup.
> I want to put the login session equal openSuse 11.0. I didn’t like the
> new one.
> How can I make this?
> Thanks for the support.
Hello Douglas,

Go into KMenu/Applications/System/Configuration/Yast/System/Bootloader

Regards / Groeten,

I don’t know whether that is exactly what douglascaixeta wanted to hear. I don’t think that there is any solution for this yet, or at least I don’t know, but GNOME tends to remove former features. (I like GNOME, don’t beat me :P)

But if you’re looking for configuration, you can install the kdm and use it, it’s pretty customizable. Install it via YaST and then go to the /etc/sysconfig-editor module in YaST and change Desktop/Display manager/DISPLAYMANAGER to kdm in the dropdown menu.


I use Gnome, not KDE.

And why there is no solution for this, in Gnome, if I can access this on openSuse 11.0? Why they take this feature off in openSuse 11.1?

I’m looking for a screen where I can change the login screen. The screen where the system ask for the username and password.
Before I had to type user and password. Now all the users are listed, and I have to click on one user, and them type the password.
I want the old login screen. The login screen from openSuse 11.0.

Anyway, at least in Ubuntu is possible to go to Gnome-look.org, and there I can download new login screen. If I do this, how can I put it in openSuse?

Thanks for the support.

P.S.: Maybe will help with the proper name: GDM. I want to change the GDM Theme.

I’m not sure if this is what you are looking for…

When booting SUSE 11.0 or 11.1 and the login screen appears, there are several session type options available. In the lower left corner of the screen, in “not very prominent print”, are the words “session_type”. Click that for a variety of desktop environments(depending what was installed), etc.

Make the “session_type” selection BEFORE completing the login.


I’m talking about “gdmsetup”. The same that they are talking about here: How Do I Change My Gdm Theme? - openSUSE Forums

But I do not have gdmsetup. If I type this on a terminal the program does not exist. Why I got access to this in openSuse 11.0, easily by Control Center, and now, in openSuse 11.1 I cannot see??

That is exactly what I’m trying to do. But I don’t have the option of the step 5:

 1) Find a theme you like.

    1a) Go to http://www.gnome-look.org.
    1b) Click on "GDM Themes" on the menu to the left.
    1c) Click on the "Highest Rated" tab, near the top of the content area.
    1d) Select a theme that you like. For this example, we will be using Avio-GDM, which is a theme that I like so much that three Fedora Core 5 boxes under my control are using it.

2) Download the theme

    2a) On the theme's page, click the "Download" link.
    2b) Save the file -- in my case, 37395-Avio-GDM.tar.gz -- to your Desktop.

3) Unpack the theme.

    3a) Right-click on the *.tar.gz file that you downloaded.
    3b) Select "Extract Here" from the menu.
    3c) A folder with the contents of the *.tar.gz file now exists on your Desktop. In my case, the folder is called "Avio-GDM".

4) Move the folder to your themes directory.

    4a) Open a terminal (Applications > Accessories > Terminal).
    4c) Become root: Run "su", and enter the root password when prompted.
    4d) Go to where the theme is presently: "cd Desktop".
    4e) Move the folder to the GDM theme directory: "mv Avio-GDM /usr/share/gdm/themes/". Obviously, you will substitute the folder that contains your theme for "Avio-GDM".

5) Select your theme to be the one used.

    5a) Run System > Administration > Login Screen. Enter your root password if you are prompted for it.
    5b) Click on the radio button (the little circle) next to the theme you want to use.

6) Configure the face browser

    These are the user account buttons that appear that can be clicked, similar to Microsoft Windows XP Home Edition.
    6a) Go to the Users tab of the Login Window Preferences window.
    6b) Click the Add button under the Include section (on the left).
    6c) Type the name of the user account you wish to have listed on the login screen.
    6d) Repeat steps 6b and 6c until all human accounts are added (or at least the ones you want to be listed).

7) See the results.

    7a) Close all open windows.
    7b) Log Out (System > Log Out).

8) Enjoy the results. 

I have the exact same problem. No options to change the gdm theme or setup.
Are the Suse developers locking us as far as options are concerned?

Well, the menu is AFAIK not available for this version of gdm, which is the samekind of gdm which Fedora uses, and back there I wasn’t able to find a solution either. I solved it by using kdm, you don’t need KDE to use it. It’s not the fault of the openSUSE developers, as I mentioned before sometimes the GNOME people think that configurability is just confusing :wink:

Thank You I am facing the same “problem” here. Now everyone can see all the usernames on my system. Before that you had to type BOTH, username AND password it was easy, you just changed /etc/sysconfig/displaymanager to gdm and that was it. After the boot you got a line to type in your username, now we have a list like in M$ systems.

It’s simple:

  1. click on the user you want to log in as
  2. the session menu appears at the bottom of gdm.


This is a prime example of BAD DESIGN. Options should not appear/disappear.

Yes, finally I figured out.

Features/NewGdm - FedoraProject

Seems that our friends are changing the system.

Why they have to take the gdmsetup out before deliver the new one???:::\

Anyway, we will have to wait…

In that page that I just post, above, they say that the new gdmsetup will be Greeter.

So I look on YaST, to install software, and there is a Greeter openSuse.

I installed and to run is ggreeter.
That looks like a substitute for gdmsetup, but only for openSuse.

But when I try to run I receive the following error:

Unhandled Exception: GLib.GException: Falha ao contatar o servidor de configuração; algumas das causas possíveis são: necessidade de habilitar rede TCP/IP no ORBit ou existência de arquivos de bloqueio deixados para trás no NFS devido a algum um erro do sistema. Para mais informações consulte: http://www.gnome.org/projects/gconf/. (Detalhes -  1: Falha ao conectar à sessão: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
  at GConf.Client.Get (System.String key) [0x00000] 
  at Greeter.Presenter.Main (System.String] args) [0x00000] 

ggreeter is definetely and in no way something similar to gdmsetup. Remember the message you reveived after installing openSUSE? This window which said: “Have fun” and gave some links?
That’s ggreeter, more precisely ggreeter.exe, so maybe you’re missing some Mono dependencies or something like this.